zoukankan      html  css  js  c++  java
  • [解题报告]HDU 1004 Let the Balloon Rise

    Let the Balloon Rise

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 50554    Accepted Submission(s): 18117


    Problem Description
    Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

    This year, they decide to leave this lovely job to you. 
     
    Input
    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

    A test case with N = 0 terminates the input and this test case is not to be processed.
     
    Output
    For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
     
    Sample Input
    5 green red blue red red 3 pink orange pink 0
     
    Sample Output
    red pink
     
    Author
    WU, Jiazhi
     
    Source
     
    Recommend
    JGShining
     
     
     
     
     
     
     
     
     
    用color[1000][16]来存储颜色信息
    用num[1000]来统计每个颜色出现的次数
    先输入一个颜色,从第二个颜色的输入开始,每输入一个,都要和之前输入的所有颜色进行比较,若是一样,则在数组对应位置上+1,
    3
    color[0] pink    
    color[1] pink num[1]=2
    color[2] blue num[2]=1
    然后在num[1000]中查找最大数,输出其下标,找到对应的颜色输出
     
    #include <stdio.h>
    #include <string.h>
    int main()
    {
        int n,i,j,num[1000];
        int max=0,t=0;
        char color[1000][16];
        while(scanf("%d",&n)!=EOF)
        {
            if(n)
            {
                num[0]=0;
                scanf("%s",color[0]);
                for(i=1;i<n;i++)
                {
                    num[i]=0;
                    scanf("%s",color[i]);
                    for(j=0;j<i-1;j++)
                        if(strcmp(color[i],color[j])==0) num[i]+=1;
                }
                max=0;
                t=0;
                for(i=1;i<n;i++)
                   if(max<num[i]) 
                   {
                       max=num[i];
                       t=i;}
                printf("%s\n",color[t]);
            }
        }
    }
  • 相关阅读:
    第十二周作业
    十一周作业
    第十周作业
    第九周作业
    2019年春第八周作业
    第五周课程总结&实验报告(三)
    第四周课程总结&实验报告(二)
    第三周课程总结&实验报告(一)
    第二周课程总结
    2019春总结作业
  • 原文地址:https://www.cnblogs.com/TheLaughingMan/p/2956376.html
Copyright © 2011-2022 走看看