zoukankan      html  css  js  c++  java
  • [解题报告]HDU 1049 Climbing Worm

    Climbing Worm

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 9062    Accepted Submission(s): 5908


    Problem Description
    An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We'll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we'll assume the worm makes it out.
     
    Input
    There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.
     
    Output
    Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.
     
    Sample Input
    10 2 1 20 3 1 0 0 0
     
    Sample Output
    17 19
     
    Source
     
     
     
     
    水题,不要图方便把升降结合在一起,就照题意做
    #include<stdio.h>
    int main()
    {
        int d,u,n,x,time;
        while(scanf("%d %d %d",&n,&u,&d)!=EOF&&d<u&&n<100&&n>0)
        {
            x=0;time=0;
            while(1)
            {
                x+=u;time++;
                if(x>=n) break;
                x-=d;time++;
            }
            printf("%d\n",time);
        }
        return 0;
    }
  • 相关阅读:
    SAPHANA学习(3):SQL Function(B)
    如何运营一家数据标注公司 (市场结构篇)
    如何运营一家数据标注公司 (基础架构篇)
    数据标注行业知多少
    数据标注-人工智能高速路上的基石
    背景图片位置设置
    ios去除textarea内阴影
    IOS系统去除点击阴影
    select文本居中
    DIV四周添加阴影
  • 原文地址:https://www.cnblogs.com/TheLaughingMan/p/2966882.html
Copyright © 2011-2022 走看看