zoukankan      html  css  js  c++  java
  • [解题报告]HDU 1096 A+B for InputOutput Practice (VIII)

    A+B for Input-Output Practice (VIII)

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 68769    Accepted Submission(s): 21074


    Problem Description
    Your task is to calculate the sum of some integers.
     
    Input
    Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 
     
    Output
    For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
     
    Sample Input
    3 4 1 2 3 4 5 1 2 3 4 5 3 1 2 3
     
    Sample Output
    10 15 6
     
    Author
    lcy
     
     
     
     
    一直没过不是你的错,是因为最后一个输出不用换行了。。。
     
    #include<stdio.h>
    int main()
    {
        int n;
        int m;
        scanf("%d",&m);
        while(m--)
        {
            scanf("%d",&n);
            int sum=0;
            while(n--)
        {
            int a;
            scanf("%d",&a);
            sum+=a;
        }
        printf("%d\n",sum);
        if(m) printf("\n");
        }
        return 0;
    }
  • 相关阅读:
    C语言与水仙花数
    C语言break和continue
    C语言中常量
    C语言中计算变量占用内存空间
    C语言中if语句
    JavaScript放置位置区别
    单选按钮中实现点击文字选中
    C语言(4)
    C语言(3)
    【第四课】kaggle案例分析四
  • 原文地址:https://www.cnblogs.com/TheLaughingMan/p/2983206.html
Copyright © 2011-2022 走看看