zoukankan      html  css  js  c++  java
  • [解题报告]HDU 1038 Biker's Trip Odometer

    Biker's Trip Odometer

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 2634    Accepted Submission(s): 1782


    Problem Description
    Most bicycle speedometers work by using a Hall Effect sensor fastened to the front fork of the bicycle. A magnet is attached to one of the spokes on the front wheel so that it will line up with the Hall Effect switch once per revolution of the wheel. The speedometer monitors the sensor to count wheel revolutions. If the diameter of the wheel is known, the distance traveled can be easily be calculated if you know how many revolutions the wheel has made. In addition, if the time it takes to complete the revolutions is known, the average speed can also be calculated. 
    For this problem, you will write a program to determine the total distance traveled (in miles) and the average speed (in Miles Per Hour) given the wheel diameter, the number of revolutions and the total time of the trip. You can assume that the front wheel never leaves the ground, and there is no slipping or skidding.
     
    Input
    Input consists of multiple datasets, one per line, of the form:

    diameter revolutions time

    The diameter is expressed in inches as a floating point value. The revolutions is an integer value. The time is expressed in seconds as a floating point value. Input ends when the value of revolutions is 0 (zero).
     
    Output
    For each data set, print:

    Trip #N: distance MPH

    Of course N should be replaced by the data set number, distance by the total distance in miles (accurate to 2 decimal places) and MPH by the speed in miles per hour (accurate to 2 decimal places). Your program should not generate any output for the ending case when revolutions is 0.

    Constants

    For p use the value: 3.1415927.
    There are 5280 feet in a mile.
    There are 12 inches in a foot.
    There are 60 minutes in an hour.
    There are 60 seconds in a minute.
    There are 201.168 meters in a furlong.
     
    Sample Input
    26 1000 5 27.25 873234 3000 26 0 1000
     
    Sample Output
    Trip #1: 1.29 928.20 Trip #2: 1179.86 1415.84
     
    Source
     

    超水!!

    #include<stdio.h>
    #define PI 3.1415927
    int main()
    {
        int t=1;
        double dia,rev,tim;
        while(scanf("%lf%lf%lf",&dia,&rev,&tim)!=EOF&&rev!=0)
        {
            double dis,MPH;
            dis=(dia*rev*PI)/(5280*12);
            MPH=(dis*3600)/tim;
            printf("Trip #%d: %.2lf %.2lf\n", t++, dis, MPH);
        }
        return 0;
    }
  • 相关阅读:
    【二分+字符串hs】[POI2000] 公共串
    【字符串匹配】【BKDRhash||KMP】
    【LCA】P4281 [AHOI2008]紧急集合 / 聚会
    【LCA专题】各种LCA求法
    【差分约束】POJ3159/LG P1993 小K的农场
    【差分约束】POJ1364/LG UVA515 king
    【差分约束】POJ1201/LG SP116 Intervals
    【差分约束】POJ3159 Candies
    【树形结构】LG P2052 [NOI2011]道路修建
    【拓扑排序+概率】LG P4316绿豆蛙的归宿
  • 原文地址:https://www.cnblogs.com/TheLaughingMan/p/2987613.html
Copyright © 2011-2022 走看看