zoukankan      html  css  js  c++  java
  • Oil Deposits( hdu1241

    http://acm.hust.edu.cn/vjudge/contest/view.action?cid=82828#problem/L
    Oil Deposits
    Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
    Submit Status

    Description

    The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 
     

    Input

    The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 
     

    Output

    For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets. 
     

    Sample Input

    1 1
    *
    3 5
    *@*@*
    **@**
    *@*@*
    1 8
    @@****@*
    5 5
    ****@
    *@@*@
    *@**@
    @@@*@
    @@**@
    0 0
     

    Sample Output

    0 1 2 2
    #include<iostream>
    #include<algorithm>
    #include<cstring>
    #include<cstdio>
    #include<queue>
    #include<cmath>
    
    using namespace std;
    
    #define N 110
    
    char maps[N][N];
    int m, n;
    
    void DFS(int o, int p);
    int dir[8][2] = { {-1,-1},{-1,0},{-1,1},{0,-1},{0,1},{1,-1},{1,0},{1,1}};
    
    int main()
    {
        int i, j, cou;
    
        while(cin >> m >> n, m+n)
        {
            cou = 0;
    
            for(i = 0; i < m; i++)
                cin >> maps[i];
    
            for(i = 0; i < m; i++)
                for(j = 0; j < n; j++)
                {
                    if(maps[i][j] == '@')
                    {
                        cou++;
                        DFS(i, j);
                    }
                }
    
            cout << cou << endl;
        }
    
        return 0;
    }
    
    void DFS(int o, int p)
    {
        int i, q, w;
    
        maps[o][p] = '*';
    
        for(i = 0; i < 8; i++)
        {
            q = o + dir[i][0];
            w = p + dir[i][1];
    
            if(q >= 0 && q < m && w >= 0 && w < n && maps[q][w] == '@')
                DFS(q, w);
        }
    }
    让未来到来 让过去过去
  • 相关阅读:
    C++ 日期 & 时间
    C++ 引用
    C++ 指针
    C++ 字符串
    C++ 数组
    C++ 数字
    C++ 函数
    C++ 判断
    C++ 循环
    C++ 运算符
  • 原文地址:https://www.cnblogs.com/Tinamei/p/4651735.html
Copyright © 2011-2022 走看看