zoukankan      html  css  js  c++  java
  • Tempter of the Bone

    Tempter of the Bone

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 87199    Accepted Submission(s): 23744


    Problem Description
    The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

    The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
     
    Input
    The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

    'X': a block of wall, which the doggie cannot enter; 
    'S': the start point of the doggie; 
    'D': the Door; or
    '.': an empty block.

    The input is terminated with three 0's. This test case is not to be processed.
     
    Output
    For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
     
    Sample Input
    4 4 5
    S.X.
    ..X.
    ..XD
    ....
    3 4 5
    S.X.
    ..X.
    ...D
    0 0 0
     
    Sample Output
    NO
    YES
     
    /*
    0 1 0 1 0 1
    1 0 1 0 1 0
    0 1 0 1 0 1
    1 0 1 0 1 0
    0 1 0 1 0 1
    */
     
    #include<iostream>
    #include<cmath>
    #include<cstring>
    
    using namespace std;
    
    #define N 15
    
    char maps[N][N];
    
    int n, m, t, flag, dx, dy, vis[N][N];
    int dir[4][2] = { {0,1}, {0, -1}, {1, 0}, {-1, 0}};
    
    void dfs(int x, int y, int k)
    {
        if(flag) return ;
    
        if(x == dx && y == dy && k == 0) flag = 1;  // 如果正好到达,flag = 1;
    
        int tmp = abs(x - dx) + abs(y-dy); 
    
        if(k < tmp) return ;   // 如果所剩步数比所需步数 tmp小,return
     
        for(int i = 0; i < 4; i++)
        {
            int nx, ny;
            nx = x + dir[i][0]; 
            ny = y + dir[i][1];
    
            if(nx >= 0 && nx < n && ny >= 0 && ny < m && maps[nx][ny] != 'X' && !vis[nx][ny])
            {
                vis[nx][ny] = 1; 
                dfs(nx, ny, k-1);
                vis[nx][ny] = 0;
            }
        }
    }
    
    int main()
    {
        int sx, sy;
        while(cin >> n >> m >> t, n+m+t)
        {
            flag = 0; 
            memset(vis, 0, sizeof(vis));  // 每次都要清0;
    
            for(int i = 0; i < n; i++)
                for(int j = 0; j < m; j++)
            {
                cin >> maps[i][j]; 
    
                if(maps[i][j] == 'S') 
                    sx = i, sy = j; 
                else if(maps[i][j] == 'D')
                    dx = i, dy = j; 
            }
            int q = (sx+sy)%2, w = (dx+dy)%2;    
            vis[sx][sy] = 1;
            if((q+w)%2 == t%2)     // 剪枝,如果到达所需步数和所给 t 奇偶性不一样的话,就不执行dfs了,no
                dfs(sx, sy, t); 
            if(flag)
                cout << "YES" << endl;
            else cout << "NO" << endl;
        }
        return 0;
    }
    让未来到来 让过去过去
  • 相关阅读:
    MYSQL设置允许所有访问
    解决ios端的H5,input有阴影的问题
    linux查看某个时间段的日志(sed -n)
    centos如何创建自启动脚本
    laravel做数据迁移的时候进行表的注释
    taro编译微信小程序,报错“未找到setmap.json文件”
    java百科常识
    spring自动装配
    top命令内容详解
    jemter 随机取数组里面的值放入请求
  • 原文地址:https://www.cnblogs.com/Tinamei/p/4661445.html
Copyright © 2011-2022 走看看