zoukankan      html  css  js  c++  java
  • pat 1058. A+B in Hogwarts (20)

    1058. A+B in Hogwarts (20)

    时间限制
    50 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

    Input Specification:

    Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

    Output Specification:

    For each test case you should output the sum of A and B in one line, with the same format as the input.

    Sample Input:
    3.2.1 10.16.27
    
    Sample Output:
    14.1.28
    解:开数组存值,存进位,很简单的一题,虽然卡在Galleon位上了,当该位的值大于10000000的时候,我以为可能需要取余,提交发现貌似不需要,于是直接不处理就过了。

    代码:

    #include<cstdlib>
    #include<cstdio>
    #include<iostream>
    #include<cstring>
    using namespace std;
    int main()
    {
        int a[2],b[2],c[2];
        int res[3]; //结果
        int add[3]; //进位
        char ch[4]; //'.'
        cin>>a[0]>>ch[0]>>b[0]>>ch[1]>>c[0];
        cin>>a[1]>>ch[2]>>b[1]>>ch[3]>>c[1];
    
        add[2]=(c[0]+c[1])/29;
        res[2]=(c[0]+c[1])%29;
    
        add[1]=(b[0]+b[1]+add[2])/17;
        res[1]=(b[0]+b[1]+add[2])%17;
    
        res[0]=(a[0]+a[1]+add[1]);
         
        cout<<res[0]<<'.'<<res[1]<<'.'<<res[2]<<endl;
    }

    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    icmp_ping学习笔记
    学习笔记
    解决Safari高版本浏览器中默认禁用第三方COOKIE(含demo)
    基础算法之插入排序Insertion Sort
    基础算法之选择排序Selection Sort
    基础算法之快速排序Quick Sort
    基础算法之冒泡排序Bubble Sort
    for语句嵌套循坏性能的剖析
    2014——>2015,我的薪资依然是4.5
    C# 反射浅析
  • 原文地址:https://www.cnblogs.com/Tobyuyu/p/4965290.html
Copyright © 2011-2022 走看看