zoukankan      html  css  js  c++  java
  • pat 1042. Shuffling Machine (20)

    1042. Shuffling Machine (20)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

    The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

    S1, S2, ..., S13, H1, H2, ..., H13, C1, C2, ..., C13, D1, D2, ..., D13, J1, J2

    where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer K (<= 20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

    样例输入:

    2
    36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

    样例输出:

    S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

    解:这题我做完想骂人,看了好久愚蠢的我刚刚看出来怎么回事,写完发现自己答案输出的方式不对。关键代码如下,这是解题的关键,模拟下就知道洗牌过程了。做完整个人觉得过程就是:先存已知54个牌序,再对每张牌编号1-54,根据输入的牌序和洗牌次数,得出每张牌最终对应的位置,这里是按照编号来的,比如说第一张牌S1对应的位置是5,一直到J2。但是输出的时候要注意,不能for(i=1;i<=54;i++) cout<<;  我们得到的是按牌编号来的位置,但是题目要求是按照位置从1-54输出对应的牌。这里也是我最后卡了很久才意识到的,后来用了map,key为牌的位置,value为牌的编号,编号我用整数1-54存储的,但是题目要求的是S1-S13,H1-H13等,这里自己输出的时候注意下就行了,很简单。

     int temp=res[i];
     res[i]=a[temp];

    代码:
    #include<iostream>
    #include<cstdlib>
    #include<cstring>
    #include<cmath>
    #include<stdio.h>
    #include<stdlib.h>
    #include<algorithm>
    #include<string.h>
    #include<map>
    using namespace std;
    int h1[100];//1-54
    string h2[100];
    int main()
    {
        int times;
        while(cin>>times)
        {
            int a[100];  //牌位信息
            int res[100]; //结果对应的位置
            for(int i=1;i<=54;i++)
            {
                h1[i]=i;
                cin>>a[i];
                res[i]=i;
            }
            for(int i=1;i<=54;i++)
            {
                for(int j=1;j<=times;j++)
                {
                    int temp=res[i];
                    res[i]=a[temp];
                }
            }
            map<int,int> ma;
            for(int i=1;i<=54;i++)
            {
                ma[res[i]]=i;
            }
            //test:
    //        for(int i=1;i<=54;i++)
    //        {
    //            cout<<ma[i]<<' ';
    //        }
    //        cout<<endl;
            for(int i=1;i<=54;i++)
            {
                 if(ma[i]>=1&&ma[i]<=13)
                 {
                    cout<<"S"<<ma[i];
                 }
                 if(ma[i]>=14&&ma[i]<=26)
                 {
                    cout<<"H"<<ma[i]-13;
                 }
                 if(ma[i]>=27&&ma[i]<=39)
                 {
                    cout<<"C"<<ma[i]-26;
                 }
                 if(ma[i]>=40&&ma[i]<=52)
                 {
                    cout<<"D"<<ma[i]-39;
                 }
                if(ma[i]>=53&&ma[i]<=54)
                {
                    cout<<"J"<<ma[i]-52;
                }
                if(i!=54)
                    cout<<' ';
            }
            cout<<endl;
        }
    }

    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    godep使用
    golang导入包的几个说明:import
    X-Frame-Options 响应头
    HTTP Strict Transport Security
    为什么我们要使用HTTP Strict Transport Security?
    IFrame安全问题解决办法(跨框架脚本(XFS)漏洞)
    基于iframe的CFS(Cross Frame Script)和Clickjacking(点击劫持)攻击
    javaWeb防止恶意登陆或防盗链的使用
    关于Cookie 的HttpOnly属性(java/web操作cookie+Tomcat操作jsessionid)
    会话cookie中缺少HttpOnly属性 解决
  • 原文地址:https://www.cnblogs.com/Tobyuyu/p/4965293.html
Copyright © 2011-2022 走看看