zoukankan      html  css  js  c++  java
  • pat 1092. To Buy or Not to Buy (20)

    1092. To Buy or Not to Buy (20)

    时间限制
    100 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is "Yes", please tell her the number of extra beads she has to buy; or if the answer is "No", please tell her the number of beads missing from the string.

    For the sake of simplicity, let's use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.


    Figure 1

    Input Specification:

    Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

    Output Specification:

    For each test case, print your answer in one line. If the answer is "Yes", then also output the number of extra beads Eva has to buy; or if the answer is "No", then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

    Sample Input 1:
    ppRYYGrrYBR2258
    YrR8RrY
    
    Sample Output 1:
    Yes 8
    
    Sample Input 2:
    ppRYYGrrYB225
    YrR8RrY
    
    Sample Output 1:
    No 2
    解: 写的比较烂,普通思路,代码比较冗长。

       如果buyer出现的字符均出现在owner里,即Yes,还需要买的数量等于第一个字符串长减去第二个字符串长,需要讲的一点就是每一次遍历要对已经查到的字符进行标记,即我们要保证buyer出现的字符个数应该在owner里都有,比如Y,buyer里出现两个,那么owner里也至少应该有两个,这里我对已经查到的字符标记为@。 

       如果buyer出现的某个字符,在owner里没有找到,即No,缺的个数可以在遍历中利用变量进行累加计数,我用的是变量cnt。

    代码:

    #include<cstdlib>
    #include<cstdio>
    #include<cstring>
    #include<iostream>
    using namespace std;
    int main()
    {
        string owner;
        string buyer;
        while(cin>>owner>>buyer)
        {
            int len1=owner.length();
            int len2=buyer.length();
            int cnt=0;
            int *flag=new int[len2+1];
            for(int i=0;i<len2;i++)
            {
                flag[i]=0;
                for(int j=0;j<len1;j++)
                {
                    if(buyer[i]==owner[j])
                    {
                        flag[i]=1;
                        owner[j]='@';
                        break;
                    }
                }
                if(flag[i]==0)
                {
                    cnt++;
                }
            }
            int choice=0;
            for(int i=0;i<len2;i++)
            {
                if(flag[i]==0)
                {
                    choice=1;
                }
            }
            if(choice==1)
                cout<<"No"<<" "<<cnt<<endl;
            if(choice==0)
                cout<<"Yes"<<" "<<len1-len2<<endl;
        }
        return 0;
    }
    

    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    Cocos2d-x 内存管理
    Cocos2d-x 解惑
    前端最实用、全面的工具类方法
    Java web 项目获取时间的方式列举
    Win系统常用指令
    Js三级下拉列表联动
    Js数组操作
    常用网站推荐
    最常用的正则表达式
    Oracle数据库学习
  • 原文地址:https://www.cnblogs.com/Tobyuyu/p/4965301.html
Copyright © 2011-2022 走看看