zoukankan      html  css  js  c++  java
  • 南阳理工oj_The Triangle

    The Triangle
    时间限制:1000 ms | 内存限制:65535 KB
    难度:4
    描述
    7
    3 8
    8 1 0
    2 7 4 4
    4 5 2 6 5
    (Figure 1)
    Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

    输入
    Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
    输出
    Your program is to write to standard output. The highest sum is written as an integer.
    样例输入
    5
    7
    3 8
    8 1 0
    2 7 4 4
    4 5 2 6 5
    样例输出
    30
    上传者
    苗栋栋

    #include <iostream>
    #include <cstdio> 
    #include <algorithm>
    #include <string>
    #include <cstring>
    #include <cstdlib>
    using namespace std;
    
    int a[110][110], dp[110][110];
    #define mem(a) memset(a, 0, sizeof(a))
    
    int main() {
        int n;
        while (cin >> n) {
            mem(a);     mem(dp);
            for (int i = 0; i<n; i++) {
                for (int j = 0; j<=i; j++) {
                    cin >> a[i][j];
                }
            }
            for (int i = 0; i<n; i++)   dp[n-1][i] = a[n-1][i];
            for (int i = n-2; i>=0; i--) {
                for (int j = i; j>=0; j--) {
                    dp[i][j] = max(a[i][j] + dp[i+1][j], a[i][j] + dp[i+1][j+1]);
                }
            }
            cout << dp[0][0] << endl;
        }
        return 0;
    } 
  • 相关阅读:
    用Intellij idea创建Maven项目JDK8源码阅读环境问题整理
    咱的Maven项目能用Junit5吗?
    43- 8 mvc知识点
    42-7 linq
    (Ant编程) Iqueryable 类型介绍
    Iqueryable 类型中 的 使用lambda 注意的坑。 (linq to sql)
    (Ant编程) Linq 的select 方法
    Scala模式匹配
    scala正则表达式
    P4336 [SHOI2016]黑暗前的幻想乡
  • 原文地址:https://www.cnblogs.com/Tovi/p/6194793.html
Copyright © 2011-2022 走看看