zoukankan      html  css  js  c++  java
  • 哈希表

    Eqs
    Time Limit:5000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

    Description

    Consider equations having the following form: 
    a1x1 3+ a2x2 3+ a3x3 3+ a4x4 3+ a5x5 3=0 
    The coefficients are given integers from the interval [-50,50]. 
    It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}. 

    Determine how many solutions satisfy the given equation. 

    Input

    The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

    Output

    The output will contain on the first line the number of the solutions for the given equation.

    Sample Input

    37 29 41 43 47

    Sample Output

    654
    
    
    
    
    首先将等式做一个简单的变换:  -(a1*x1^3 + a2*x2^3) = a3*x3^3+a4*x4^3+a5*x5^3      ,然后运用哈希表!
    
    
    
    
    
    
    #include <iostream>
    #include <cstdlib>
    using namespace std;
    
    #define sum 25000001
    short a[sum];
    
    int main()
    {
    	int a1, a2, a3, a4, a5;
    	cin >> a1>> a2>> a3>> a4>> a5;
    	memset(a, 0, sum);
    	for (int x1 = -50; x1<=50; x1++)
    	{
    		if ( !x1 )
    			continue;
    		for (int x2 = -50; x2<=50; x2++)
    		{
    			if ( !x2 )
    				continue;
    			int sum1 = (a1*x1*x1*x1 + a2*x2*x2*x2) *(-1);
    			if (sum1 < 0)
    				sum1 = sum1 + 25000000;
    			a[sum1] ++ ;
    		}
    	}
    	int num = 0;
    	for (int x3 = -50; x3<=50; x3++)
    	{
    		if ( !x3 )
    			continue;
    		for (int x4 = -50; x4<=50; x4++)
    		{
    			if ( !x4 )
    				continue;
    			for (int x5 = -50; x5<=50; x5++)
    			{
    				if ( !x5 )
    					continue;
    				int sum2 = a3*x3*x3*x3 + a4*x4*x4*x4 + a5*x5*x5*x5;
    				if (sum2 < 0)
    					sum2 = sum2 + 25000000;
    				if (a[sum2])
    					num = num + a[sum2];
    			}
    		}
    	}
    	cout << num << endl;
    	return 0;
    }


  • 相关阅读:
    NTP时间同步
    《暗时间》
    寻找字典公共键
    maven pom.xml的execution报错
    maven安装scala插件
    html 和xml
    sparkstreaming+kafka
    zookeeper错误Error contacting service. It is probably not running.
    eclipse开发hive2程序
    eclipse开发hbase程序
  • 原文地址:https://www.cnblogs.com/Tovi/p/6194868.html
Copyright © 2011-2022 走看看