zoukankan      html  css  js  c++  java
  • HDU--1061

    Rightmost Digit

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 39389    Accepted Submission(s): 14863


    Problem Description
    Given a positive integer N, you should output the most right digit of N^N.
     

    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case contains a single positive integer N(1<=N<=1,000,000,000).
     

    Output
    For each test case, you should output the rightmost digit of N^N.
     

    Sample Input
    2 3 4
     

    Sample Output
    7 6
    Hint
    In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
     

    Author
    Ignatius.L
    #include <iostream>
    #include <algorithm>
    #include <cstdio>
    using namespace std;
    
    long long int powermod(long long int a,long long int b,long long int c)
    {
        long long int ans = 1;
        a = a%c;
        while (b > 0)
        {
            if (b% 2 ==1)
                ans = ans * a %c;
            b = b/2;
            a = a* a %c;
        }
        return ans;
    }
    
    int main()
    {
        int t;
        long long int n;
        cin >> t;
        while (t--)
        {
            cin >> n;
            cout <<powermod(n,n,10) << endl;
        }
        return 0;
    }

    快速幂求余!
  • 相关阅读:
    全端开发必备!10个最好的 Node.js MVC 框架
    action和servlet的关系
    js模块化
    前端类库
    Windows下配置nginx+php(wnmp)
    DllMain的作用
    在linux上实现DllMain + 共享库创建方法
    QT实现Windows下DLL程序编写
    平台相关的宏
    远程线程的注入 PE的修正
  • 原文地址:https://www.cnblogs.com/Tovi/p/6194880.html
Copyright © 2011-2022 走看看