zoukankan      html  css  js  c++  java
  • 【菜鸟做水题】:杭电 hide handkerchief (辗转相除判断2数互质)

     

    Problem Description
    The Children’s Day has passed for some days .Has you remembered something happened at your childhood? I remembered I often played a game called hide handkerchief with my friends.
    Now I introduce the game to you. Suppose there are N people played the game ,who sit on the ground forming a circle ,everyone owns a box behind them .Also there is a beautiful handkerchief hid in a box which is one of the boxes .
    Then Haha(a friend of mine) is called to find the handkerchief. But he has a strange habit. Each time he will search the next box which is separated by M-1 boxes from the current box. For example, there are three boxes named A,B,C, and now Haha is at place of A. now he decide the M if equal to 2, so he will search A first, then he will search the C box, for C is separated by 2-1 = 1 box B from the current box A . Then he will search the box B ,then he will search the box A.
    So after three times he establishes that he can find the beautiful handkerchief. Now I will give you N and M, can you tell me that Haha is able to find the handkerchief or not. If he can, you should tell me "YES", else tell me "POOR Haha".
     
    Input
    There will be several test cases; each case input contains two integers N and M, which satisfy the relationship: 1<=M<=100000000 and 3<=N<=100000000. When N=-1 and M=-1 means the end of input case, and you should not process the data.
     
    Output
    For each input case, you should only the result that Haha can find the handkerchief or not.
     
    Sample Input
    3 2
    -1 -1
     
    Sample Output
    YES
     
     

    代码:

    #include<iostream>
    #include<fstream>
    using namespace std;
    
    int main()
    {
        int n,m;
        while(cin >> n >> m && n != -1 && m != -1)
        {
            int r;
            while( n % m != 0)
            {
                 r = n % m;
                 n = m;
                 m = r;
            }
                 if( m == 1)
                     cout << "YES" << endl;
                 else
                     cout << "POOR Haha" << endl;
            
        }
        return 0;
    }
    

      

     

    给梦想一点时间
  • 相关阅读:
    _allow_resetlogs_corruption打开数据库
    增量备份恢复DATAGUARD(出现gap并后续有新增数据文件,主从数据文件路径一致)
    dataguard环境破坏后采用rman备份集重新部署
    表空间数据文件迁移到另外的位置(backup as copy tablespace)
    pl/sql无法登录12c问题
    ORA-00845: MEMORY_TARGET not supported on this system
    dataguard主库添加的数据文件路径在从库不存在
    12c expdp
    表进行加密(redact)实验
    创建触发器启动pdb
  • 原文地址:https://www.cnblogs.com/VortexPiggy/p/2669396.html
Copyright © 2011-2022 走看看