zoukankan      html  css  js  c++  java
  • The Accomodation of Students HDU

    The Accomodation of Students

    Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 8418    Accepted Submission(s): 3709


    Problem Description
    There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

    Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

    Calculate the maximum number of pairs that can be arranged into these double rooms.
     
    Input
    For each data set:
    The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

    Proceed to the end of file.

     
    Output
    If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.
     
    Sample Input
    4 4 1 2 1 3 1 4 2 3 6 5 1 2 1 3 1 4 2 5 3 6
     
    Sample Output
    No 3
     
    Source
     
    Recommend
    gaojie

    先判断能不能分成二分图 , 不是就输出No。。只有1个的时候也不是

    然后求完美匹配即可。。。我不会写匈牙利了。。。。只会写hk。。。还是套模板。。。

    因为没有分左右  所以要除2 

    #include <iostream>
    #include <cstring>
    #include <cstdio>
    #include <algorithm>
    #include <cmath>
    #include <queue>
    #include <vector>
    #define mem(a, b) memset(a, b, sizeof(a))
    using namespace std;
    const int maxn = 10010, INF = 0x7fffffff;
    int dx[maxn], dy[maxn], cx[maxn], cy[maxn], used[maxn], vis[maxn];
    int nx, ny, dis;
    vector<int> G[40005];
    int n, m;
    int bfs()
    {
        queue<int> Q;
        dis = INF;
        mem(dx, -1);
        mem(dy, -1);
        for(int i=1; i<=nx; i++)
        {
            if(cx[i] == -1)
            {
                Q.push(i);
                dx[i] = 0;
            }
        }
        while(!Q.empty())
        {
            int u = Q.front(); Q.pop();
            if(dx[u] > dis) break;
            for(int v=0; v<G[u].size(); v++)
            {
                int i = G[u][v];
                if(dy[i] == -1)
                {
                    dy[i] = dx[u] + 1;
                    if(cy[i] == -1) dis = cy[i];
                    else
                    {
                        dx[cy[i]] = dy[i] + 1;
                        Q.push(cy[i]);
                    }
                }
            }
        }
        return dis != INF;
    }
    
    int dfs(int u)
    {
        for(int v=0; v<G[u].size(); v++)
        {
            int i=G[u][v];
            if(!used[i] && dy[i] == dx[u] + 1)
            {
                used[i] = 1;
                if(cy[i] != -1 && dis == dy[i]) continue;
                if(cy[i] == -1 || dfs(cy[i]))
                {
                    cy[i] = u;
                    cx[u] = i;
                    return 1;
                }
            }
        }
        return 0;
    }
    
    int hk()
    {
        int res = 0;
        mem(cx, -1);
        mem(cy, -1);
        while(bfs())
        {
            mem(used, 0);
            for(int i=1; i<=nx; i++)
                if(cx[i] == -1 && dfs(i))
                    res++;
        }
        return res;
    }
    
    int istwo(int u)
    {
        queue<int> E;
        mem(vis, -1);
        E.push(u);
        vis[u] = 1;
        while(!E.empty())
        {
            u = E.front(); E.pop();
            for(int i=0; i<G[u].size(); i++)
            {
                int v = G[u][i];
                if(vis[v] == -1)
                {
                    if(vis[u] == 1) vis[v] = 0;
                    else vis[v] = 1;
                    E.push(v);
                }
                else if(vis[v] == vis[u])
                    return 0;
            }
        }
        return 1;
    }
    
    
    
    int main()
    {
        while(cin>> n >> m && n+m)
        {
            for(int i=0; i<maxn; i++) G[i].clear();
    
            for(int i=0; i<m; i++)
            {
                int u, v;
                cin>> u >> v;
                G[u].push_back(v);
                G[v].push_back(u);
            }
    
            if(!istwo(1) || n == 1)
            {
                cout<< "No" <<endl;
                continue;
            }
            nx = n; ny = n;
            cout<< hk()/2 <<endl;
    
        }
    
    
        return 0;
    }
    View Code
    自己选择的路,跪着也要走完。朋友们,虽然这个世界日益浮躁起来,只要能够为了当时纯粹的梦想和感动坚持努力下去,不管其它人怎么样,我们也能够保持自己的本色走下去。
  • 相关阅读:
    Linux_Bash脚本基础
    Linux_Bash脚本基础
    Windows perl dbi oracle环境配置
    第八章 引用:
    bless 概念
    电力企业信息化建设解决方案之计量生产分析系统
    Tom和Jerry来了,Tom和Jerry走了——北漂18年(38)
    电力企业信息化建设解决方案之计量生产分析系统
    请用fontAwesome代替网页icon小图标
    Python Module_openpyxl_处理Excel表格
  • 原文地址:https://www.cnblogs.com/WTSRUVF/p/9309629.html
Copyright © 2011-2022 走看看