zoukankan      html  css  js  c++  java
  • (并查集 注意别再犯傻逼的错了) HDU 1213 How Many Tables

    Problem Description
    Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

    One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

    For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
     
    Input
    The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
     
    Output
    For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
     
    Sample Input
    2
    5 3
    1 2
    2 3
    4 5
     
    5 1
    2 5
     
    Sample Output
    2
    4
     
     
    这个是并查集基础题。
    emmmmm,我交了10多次才发现我在一个小地方上犯了傻逼的错。。。。
    C++代码:
    #include<iostream>
    #include<stdio.h>
    #include<cstring>
    using namespace std;
    const int maxn = 1010;
    int father[maxn],vis[maxn];
    int Find(int x){
        while(x != father[x]){
            father[x] = father[father[x]];
            x = father[x];
        }
        return x;
    
    }
    void Union(int a,int b){
        int ax = Find(a);
        int bx = Find(b);
        if(ax != bx){
            father[ax] = bx;
        }
    //    if(a != b)
    //        father[a] = b; //这个错的太傻逼了吧
    }
    int main(){
        int T;
        scanf("%d",&T);
        int a,b;
        while(T--){
            int n,m;
            scanf("%d%d",&n,&m);
            memset(vis,0,sizeof(vis));
            for(int i = 1; i <= n; i++)
                father[i] = i;
            for(int i = 0; i < m; i++){
                scanf("%d%d",&a,&b);
                Union(a,b);
            }
            int sum = 0;
            for(int i = 1; i <= n; i++){
                if(father[i] == i)
                    sum++;
            }
            cout<<sum<<endl;
        } 
        return 0;
    }
  • 相关阅读:
    Hashcode的作用
    java 强弱软虚 四种引用,以及用到的场景
    Object类有哪些公用方法?
    equals和==的区别
    switch能否用string做参数
    Java九种基本数据类型,以及他们的封装类
    Singleton(Java)
    快速排序和二分查找(Javascript)
    快速排序和二分查找(Go)
    ubuntn 安装 MySQL
  • 原文地址:https://www.cnblogs.com/Weixu-Liu/p/10908145.html
Copyright © 2011-2022 走看看