zoukankan      html  css  js  c++  java
  • (大数 string) Integer Inquiry hdu1047

    Integer Inquiry

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

    Total Submission(s): 22451    Accepted Submission(s): 6099

    Problem Description

    One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.

    ``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

    Input

    The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

    The final input line will contain a single zero on a line by itself.

    Output

    Your program should output the sum of the VeryLongIntegers given in the input.

    This problem contains multiple test cases!

    The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

    The output format consists of N output blocks. There is a blank line between output blocks.

    Sample Input

    1

    123456789012345678901234567890

    123456789012345678901234567890

    123456789012345678901234567890

    0

    Sample Output

    370370367037037036703703703670

    可以用string的高精度模板进行加法运算,
    #include<iostream>
    #include<string>
    using namespace std;
    string add(string str1,string str2)
    {
        int len1=str1.length();
        int len2=str2.length();
        if(len1>len2)               //为了让长度较小的字符串前面补0,使两个字符串的长度相等。
        {
            for(int i=1;i<=len1-len2;i++)
                str2="0"+str2;
        }
        else
        {
            for(int i=1;i<=len2-len1;i++)
                str1="0"+str1;
        }
        len1=str1.length();
        int cf=0;
        int t;
        string str;
        for(int i=len1-1;i>=0;i--)             //因为最后一位数的下标就是len1-1;首位的为0。
        {
            t=str1[i]-'0'+str2[i]-'0'+cf;
            cf=t/10;                    //进位。
            t%=10;
            str=char(t+'0')+str;
        }
        if(cf!=0) str=char(cf+'0')+str;
        return str;
    }
    int main()
    {
        int t;
        cin>>t;
        while(t--)
        {
            string sum="0";
            string str1;
            while(cin>>str1)                //可以用这方法进行循环输入字符串。
            {
                if(str1=="0")break;
                sum=add(sum,str1);
            }
            cout<<sum<<endl;
            if(t)
                cout<<endl;
        }
        return 0;
    }
    View Code
    用java:
    
    import java.math.BigInteger;
    import java.util.Scanner;
    public class Main {
        public static void main(String[] args) {
            Scanner in =new Scanner(System.in);
            int t=in.nextInt();
            while(t>0) {
                t--;
                BigInteger a=new BigInteger("0");
                while(in.hasNextBigInteger()) {
                    BigInteger b=in.nextBigInteger();
                    if(!b.equals(BigInteger.valueOf(0))) {
                        a=a.add(b);
                    }
                    else {
                        System.out.println(a);
                        if(t!=0)
                            System.out.println();
                        break;
                    }
                }
            }
        }
    }
    View Code
  • 相关阅读:
    NYOJ题目28大数阶乘
    网页小图标设置
    Sass中文乱码问题(手动编译和watch编译)
    设计模式之构建者模式(Builder):初步理解
    Struts2之类型转换器
    css设置网页文本选中样式
    由超市临时储物柜引发的一点设计随想...
    前端资源相关参考资料
    Struts2拦截器之ExceptionMappingInterceptor(异常映射拦截器)
    Struts2之OGNL
  • 原文地址:https://www.cnblogs.com/Weixu-Liu/p/9164679.html
Copyright © 2011-2022 走看看