zoukankan      html  css  js  c++  java
  • (stack)Train Problem I hdu1022

    Train Problem I

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

    Total Submission(s): 42031    Accepted Submission(s): 15731

    Problem Description

    As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2

    Input

    The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.

    Output

    The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.

    Sample Input

    3 123 321

    3 123 312

    Sample Output

    Yes.

    in

    in

    in

    out

    out

    out

    FINISH

    No.

    FINISH

    Hint

    Hint

    For the first Sample Input, we let train 1 get in, then train 2 and train 3.So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.Now we can let train 3 leave.But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.So we output "No.".

     PS:emmmm,这个我不知怎么说,先贴代码吧

    #include<iostream>
    #include <stack>
    #include <cstring>
    using namespace std;
    int main()
    {
        stack<char>s1;
        stack<char>s2;
        int n,i,j,a[10000];
        char str1[100010],str2[100010];
        while(cin>>n)
        {
            memset(str1,0,sizeof(str1));
            memset(str2,0,sizeof(str2));
            cin>>str1;
            cin>>str2;
            for(i=strlen(str2)-1;i>=0;i--)
                s2.push(str2[i]);          //入栈
            for(i=0,j=0;i<strlen(str1);i++)
            {
                s1.push(str1[i]);                //入栈
                a[j++]=1;
                while(!s1.empty()&&s1.top()==s2.top())
                {
                    s1.pop();
                    s2.pop();
                    a[j++]=0;
                }
            }
                if(s1.empty()&&s2.empty())
                {
                    cout<<"Yes."<<endl;
                    for(i=0;i<2*n;i++)
                    {
                        if(a[i]==1)
                            cout<<"in"<<endl;
                        else
                            cout<<"out"<<endl;
                    }
                }
                else
                {
                    cout<<"No."<<endl;
                    while(!s1.empty())
                        s1.pop();
                    while(!s2.empty())
                        s2.pop();
                }
                cout<<"FINISH"<<endl;
        }
        return 0;
    }
  • 相关阅读:
    OracleConnection is obsolete
    ORA-12899: value too large for column (actual: 27, maximum: 20)
    快速删除有外键关联的数据库的数据
    Could not load type 'System.Reflection.AssemblySignatureKeyAttribute' from assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c
    RegSvr32注册OCX时报错
    EF:Oracle.DataAccess.Client.OracleException: ORA-12154: TNS:could not resolve the connect identifier specified
    EF:The provider did not return a ProviderManifest instance
    EF:split your EDMX file into multiple diagrams
    读《这就是搜索引擎:核心技术详解》有感总结
    c++ 类成员变量初始化总结
  • 原文地址:https://www.cnblogs.com/Weixu-Liu/p/9173717.html
Copyright © 2011-2022 走看看