zoukankan      html  css  js  c++  java
  • (map)What Are You Talking About hdu1075

    What Are You Talking About
    Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)
    Total Submission(s): 25683    Accepted Submission(s): 8745
     
     
    Problem Description
    Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
     
    Input
    The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab(' '), enter(' ') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
     
    Output
    In this problem, you have to output the translation of the history book.
     
    Sample Input
    START
    from fiwohello difhmars riwosfearth fnnvklike fiiwj
    END
    START
    difh, i'm fiwo riwosf.
    i fiiwj fnnvk!
    END
     
    Sample Output
    hello, i'm from mars.
    i like earth!
    Hint
    Huge input, scanf is recommended.
     
     
     
    方法一
    #include <cctype>
    #include <map>
    #include <iostream>
    #include <algorithm>
    using namespace std;
    string a, b;
    string s;
    map<string, string> mp;
    int main() {
    cin >> a;
    while (cin >> a) {
    if (a == "END")
    break;
    cin >> b;
    mp[b] = a;
    }
    cin >> a;
    getchar();
    while (1) {
    getline(cin,s);
    if (s=="END")
    break;
    int len = s.length(); //确定输入的字符串的长度。
    a = ""; //对字符串a初始化。
    for(int i=0;i<len;i++) {
    if (islower(s[i])) {
    a += s[i];
    } else {
    if (mp.find(a) != mp.end())
    cout << mp[a];
    else
    cout << a;
    a = ""; //对字符串进行初始化。
    cout << s[i]; //还需要输出s[i],s[i]不是小写字母,要考虑这个可能性。
    }
    }
    cout << endl;
    }
    return 0;
    }
     
    方法二:
    #include <cctype>
    #include <map>
    #include <iostream>
    #include <algorithm>
    using namespace std;
    string a, b;
    string s;
    map<string, string> mp;
    int main() {
    cin >> a;
    while (cin >> a) {
    if (a == "END")
    break;
    cin >> b;
    mp[b] = a;
    }
    cin >> a;
    getchar();
    while (1) {
    getline(cin,s);
    if (s=="END")
    break;
    int len = s.length();
    a = "";
    for(int i=0;i<len;i++) {
    if (islower(s[i])) {
    a += s[i];
    } else {
    if (mp[a]=="") //也可以这样用。
    cout<<a;
    else
    cout<<mp[a];
    a = "";
    cout << s[i];
    }
    }
    cout << endl;
    }
    return 0;
    }
     
  • 相关阅读:
    Spark学习(一)Spark初识
    service mysqld restart mysqld: 未被识别的服务
    Spark学习(二)Spark 版本 WordCount
    java.sql.SQLException: Incorrect string value: '\xE4\xB8\xAD\xE9\x83\xA8' for column 'area' at row 1
    centos 6.8 yum源不可用安装报YumRepo Error: All mirror URLs are not using ftp, http[s] or file
    互联网运维装腔指南
    PHP生成一段时间之间的月份列表
    sql根据分组后排序取第一条数据
    sql 多行拼接 成一行
    js 常用汇总
  • 原文地址:https://www.cnblogs.com/Weixu-Liu/p/9174856.html
Copyright © 2011-2022 走看看