zoukankan      html  css  js  c++  java
  • (map string)Crazy Search hdu1381

    Crazy Search
    Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 3035    Accepted Submission(s): 1133
     
     
    Problem Description
    Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.
     
    Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.
     
    As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa", "aab", "aba", "bab", "bac". Therefore, the answer should be 5.
     
    Input
    The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.
     
    Output
    The program should output just an integer corresponding to the number of different substrings of size N found in the given text.
    The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
     
    The output format consists of N output blocks. There is a blank line between output blocks.
     
     
    Sample Input
    1
    3 4
    daababac
     
    Sample Output
    5
     
    #include<iostream>
    #include <map>
    #include <string>
    using namespace std;
    int main()
    {
    int t,n,nc;
    cin>>t;
    map<string,int> m;
    while(t--){
    cin>>n>>nc;
    m.clear(); //要格式化。
    string str;
    cin>>str;
    string temp;
    int i,length;
    length=str.length();
    for(i=0;i<=length-n;i++)
    {
    temp=string(str,i,n); //截取字符串(要记住)
    if(m.count(temp)==0)
    m[temp]++;
    }
    cout<<m.size()<<endl;
    }
    return 0;
    }
     
     
  • 相关阅读:
    深入Apache NiFi 之源码学习
    Apache NiFi 核心概念和关键特性
    运营商手机视频流量包业务日志ETL及统计分析
    HDP Hive性能调优
    redis 实现登陆次数限制
    Hadoop和Spark的Shuffer过程对比解析
    Scala-基础知识
    Python基础知识问答
    Python基础知识+计算器练习
    Sqoop架构原理及常用命令参数
  • 原文地址:https://www.cnblogs.com/Weixu-Liu/p/9174857.html
Copyright © 2011-2022 走看看