zoukankan      html  css  js  c++  java
  • (next_permutation)Ignatius and the Princess II hdu102

    Ignatius and the Princess II

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

    Total Submission(s): 9444    Accepted Submission(s): 5524

    Problem Description

    Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

    "Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"

    Can you help Ignatius to solve this problem?

    Input

    The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.

    Output

    For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.

    Sample Input

    6 4 11 8

    Sample Output

    1 2 3 5 6 4 1 2 3 4 5 6 7 9 8 11 10

    #include <iostream>
    #include <algorithm>            //此处可用stl,因为这基本是字典序排序。
    using namespace std;
    int main()
    {
        int a,b,c[1010];
        while(cin>>a>>b)
        {
            for(int i=1;i<=a;i++)
                c[i]=i;
            b--;              //第四个排列,只需要进行3次排序就可。
            while(b--)
                next_permutation(c+1,c+1+a); 
            for(int i=1;i<a;i++)
                cout<<c[i]<<" ";
            cout<<c[a]<<endl;
        }
        return 0;
    }
  • 相关阅读:
    18.AutoMapper 之条件映射(Conditional Mapping)
    17.AutoMapper 之配置(Configuration)
    16.AutoMapper 之可查询扩展(Queryable Extensions)
    15. AutoMapper 之映射继承(Mapping Inheritance)
    14.AutoMapper 之依赖注入(Dependency Injection)
    13.AutoMapper 之映射前后(Before and After Map Action)
    12.AutoMapper 之Null替换(NullSubstitution)
    Windows 2012 系统汉化
    网站反屏蔽常见的六大方法
    Windows系统 本地文件如何复制到远程服务器
  • 原文地址:https://www.cnblogs.com/Weixu-Liu/p/9174928.html
Copyright © 2011-2022 走看看