zoukankan      html  css  js  c++  java
  • (Arrays.sort() 或 map) Ignatius and the Princess IV hdu1029

    Ignatius and the Princess IV

    链接:http://acm.hdu.edu.cn/showproblem.php?pid=1029

    借鉴链接:https://blog.csdn.net/tigerisland45/article/details/52146154

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32767 K (Java/Others)
    Total Submission(s): 43810    Accepted Submission(s): 19319


    Problem Description
    "OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

    "I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

    "But what is the characteristic of the special integer?" Ignatius asks.

    "The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

    Can you find the special integer for Ignatius?
     
    Input
    The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
     
    Output
    For each test case, you have to output only one line which contains the special number you have found.
     
    Sample Input
    5
    1 3 2 3 3
    11
    1 1 1 1 1 5 5 5 5 5 5
    7 1 1 1 1 1 1 1
     
    Sample Output
    3
    5
    1
     
    Author
    Ignatius.L
     
    这个题的题意就是:
    输入n(n是奇数),然后输入n个整数,求其中至少出现(n+1)/2次的整数(至少有(n+1)/2个整数)。
    思路:
    n是奇数,(n+1)/2是n的一半以上,只要将n个数据排序,出现(n+1)/2次的整数必然会出现在中间位置。
     
    JAVA代码:
    import java.util.Arrays;
    import java.util.Scanner;
    
    public class Main {
    
        public static void main(String[] args) {
            @SuppressWarnings("resource")
            Scanner inScanner = new Scanner(System.in);
            while(inScanner.hasNext()) {
                int n = inScanner.nextInt();
                int[] x = new int[n];  //要掌握java的数组初始化的用法。
                for(int i = 0;i<n;i++) {
                    x[i] = inScanner.nextInt();
                }
                Arrays.sort(x); //注意sort的用法,记住。
                System.out.println(x[(n+1)/2]);
            }
        }
    
    }

    C++代码:(用了map(),思路有点复杂)

    #include <iostream>
    #include <map>
    using namespace std;
    int main()
    {
        int n;
        map<int,int> a;
        while(cin>>n)
        {
            a.clear();
            int m;
            int b=n;
            while(b--)
            {
                cin>>m;
                a[m]++;
            }
            for(map<int,int>::iterator it=a.begin();it!=a.end();it++)
            {
                if(it->second>=(n+1)/2)
                {
                    cout<<it->first<<endl;
                    break;
                }
            }
        }
        return 0;
    }
  • 相关阅读:
    CSS Frameworks Collection(css框架收集)
    CSS:IE与Firefox的CSS兼容大全
    一般的 DIV + CSS 三栏式排版
    C#获取与修改HTML DOM元素信息
    101 LINQ Samples
    IE,Firefox,Chrome都可用的阴影效果
    QT中字符串编码的选用
    QT中字符串及其编码
    QT多项目编译顺序
    QT字符串编码知识汇编
  • 原文地址:https://www.cnblogs.com/Weixu-Liu/p/9655255.html
Copyright © 2011-2022 走看看