zoukankan      html  css  js  c++  java
  • (字符串 枚举)The Hardest Problem Ever hdu1048

    The Hardest Problem Ever

    链接:http://acm.hdu.edu.cn/showproblem.php?pid=1048

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 31307    Accepted Submission(s): 14491


    Problem Description
    Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cipher was so incredibly sound, that no one could figure it out without knowing how it worked.
    You are a sub captain of Caesar's army. It is your job to decipher the messages sent by Caesar and provide to your general. The code is simple. For each letter in a plaintext message, you shift it five places to the right to create the secure message (i.e., if the letter is 'A', the cipher text would be 'F'). Since you are creating plain text out of Caesar's messages, you will do the opposite:

    Cipher text
    A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

    Plain text
    V W X Y Z A B C D E F G H I J K L M N O P Q R S T U

    Only letters are shifted in this cipher. Any non-alphabetical character should remain the same, and all alphabetical characters will be upper case.
     
    Input
    Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. All characters will be uppercase.

    A single data set has 3 components:

    Start line - A single line, "START"

    Cipher message - A single line containing from one to two hundred characters, inclusive, comprising a single message from Caesar

    End line - A single line, "END"

    Following the final data set will be a single line, "ENDOFINPUT".
     
    Output
    For each data set, there will be exactly one line of output. This is the original message by Caesar.
     
    Sample Input
    START
    NS BFW, JAJSYX TK NRUTWYFSHJ FWJ YMJ WJXZQY TK YWNANFQ HFZXJX
    END
    START N BTZQI WFYMJW GJ KNWXY NS F QNYYQJ NGJWNFS ANQQFLJ YMFS XJHTSI NS WTRJ
    END
    START IFSLJW PSTBX KZQQ BJQQ YMFY HFJXFW NX RTWJ IFSLJWTZX YMFS MJ
    END
    ENDOFINPUT
     
    Sample Output
    IN WAR, EVENTS OF IMPORTANCE ARE THE RESULT OF TRIVIAL CAUSES
    I WOULD RATHER BE FIRST IN A LITTLE IBERIAN VILLAGE THAN SECOND IN ROME
    DANGER KNOWS FULL WELL THAT CAESAR IS MORE DANGEROUS THAN HE
     
    Source
     
    可以用JAVA进行枚举。
    import java.util.Scanner;
    
    public class Main {
        public static void main(String[] args) {
            @SuppressWarnings("resource")
            Scanner inScanner = new Scanner(System.in);
            while(inScanner.hasNext()) {
                String string = inScanner.nextLine();
                if(string.equals("ENDOFINPUT")) {
                    break;
                }
                else if(string.equals("START") || string.equals("END")) {
                    continue;
                }
                else {
                    for(int i = 0;i<string.length();i++) {
                        if(string.charAt(i)>='A' && string.charAt(i)<='E') {
                            System.out.printf("%c",string.charAt(i)+26-5);
                        }
                        else if(string.charAt(i)>='F'&&string.charAt(i)<='Z'){
                            System.out.printf("%c", string.charAt(i)-5);
                        }
                        else {
                            System.out.printf("%c",string.charAt(i));
                        }
                    }
                }
                System.out.println();
            }
        }
    }
  • 相关阅读:
    jquery.validate使用攻略 5
    jquery.validate使用攻略 4
    ccnet1.5集成tfs中文版的问题
    解决mysql连接异常—com.mysql.jdbc.CommunicationsException: Communications link failure due to underlying exception
    Myeclipse 6.5 增加对 JavaEE 6 的支持
    Python3.7环境配置
    myeclipse 8.6 software and workspace center is currently not available
    入坑cordova
    开启博客之路
    如何在高并发的分布式系统中产生UUID
  • 原文地址:https://www.cnblogs.com/Weixu-Liu/p/9661377.html
Copyright © 2011-2022 走看看