zoukankan      html  css  js  c++  java
  • (JAVA对进制的运算)A + B Again hdu2057 要复习

    (置顶,复习)A + B Again

    链接:http://acm.hdu.edu.cn/showproblem.php?pid=2057

    Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 35905    Accepted Submission(s): 14614


    Problem Description
    There must be many A + B problems in our HDOJ , now a new one is coming.
    Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
    Easy ? AC it !
     
    Input
    The input contains several test cases, please process to the end of the file.
    Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
    The length of A and B is less than 15.
     
    Output
    For each test case,print the sum of A and B in hexadecimal in one line.
     
    Sample Input
    +A -A
    +1A 12
    1A -9
    -1A -12
    1A -AA
     
    Sample Output
    0
    2C
    11
    -2C
    -90
     
    Author
    linle
     
    注:
    此题就是利用Long.parseLong()和Long.toHexString()的
    replaceAll("\+",""),是去除其中的‘+’,因为进制计算不支持带“+”的某一进制的数字字符串,‘-’可以,同时还需要判断正数负数,从而利用Long.toHexString()。
     
    Java代码:
    import java.util.Scanner;
    
    public class Main {
        public static void main(String[] args) {
            Scanner inScanner = new Scanner(System.in);
            while(inScanner.hasNext()) {
                long l = Long.parseLong(inScanner.next().replaceAll("\+", ""),16)
                        + Long.parseLong(inScanner.next().replaceAll("\+", ""),16);
                if(l<0) {
                    System.out.println("-" + Long.toHexString(-l).toUpperCase());
                }
                else {
                    System.out.println(Long.toHexString(l).toUpperCase());
                }
            }
        }
    }
     
  • 相关阅读:
    mycat主要参数
    Linux上通过docker方式安装mysql
    Docker镜像拉取慢的解决方法
    mysql关联、子查询索引优化
    Mysql优化单表查询
    Mysql如何快速插入100万条记录?
    git连接到github
    git分支操作2
    git基本操作1
    git简介及安装(win10)
  • 原文地址:https://www.cnblogs.com/Weixu-Liu/p/9674229.html
Copyright © 2011-2022 走看看