zoukankan      html  css  js  c++  java
  • 杭电 1114 Piggy-Bank 完全背包问题

    Piggy-Bank

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 26573    Accepted Submission(s): 13459


    Problem Description
    Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 

    But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 
     
    Input
    The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 
     
    Output
    Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.". 
     
    Sample Input
    3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4
     
    Sample Output
    The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.
     

    题目大意:

    就是有一个存钱罐,比不知道里面有多少钱,但是我们知道(就是 输入)T组测试数据 E 空的存钱罐的质量, F 存钱罐装满钱的重量,

    接着输入 N 里面硬币的种类,

    下面N行 P 硬币的价值, W 硬币的质量 你的任务是求出来存钱罐里面最少多少钱

    样例1:

    10 110

    2

    1 1

    30 50

    里面的硬币是 2个价值30,重量为50的硬币的时候,最少,故宗价值最少60.

    题目注意要点:

    1.完全背包问题,但是求的是最小值,不是最大值!所以初始化的时候做下改变: 

    求最大价值:要求恰好装满背包,那么在初始化时除了dp[0]为0其它dp[1..V]均设为-∞  

    求最小价值:要求恰好装满背包,那么在初始化时除了dp[0]为0其它dp[1..V]均设为∞  

    2.题目核心算法:

       for(int i=1;i<=n;i++)
           {
               for(int j=w[i];j<=vol;j++)
               {
                   dp[j]=min(dp[j],dp[j-w[i]]+value[i]);
               }
           }

    相比较01背包而言,这个是顺序的,01背包是逆序的。至于为什么,请参考博文:

    http://www.cppblog.com/tanky-woo/archive/2010/07/31/121803.html

    或者我的:http://www.cnblogs.com/William-xh/p/7327734.html

    3.注意输出的最后有句号,我就是因为没有句号被WA了n次。

    最后附上代码:

    #include <iostream>
    #include<math.h>
    #include <iomanip>
    #include<cstdio>
    #include<string>
    #include<map>
    #include<vector>
    #include<list>
    #include<algorithm>
    #include<stdlib.h>
    #include<iterator>
    #include<sstream>
    #include<string.h>
    #include<stdio.h>
    using namespace std;
    
    
    int main()
    {
       int t;
       cin>>t;
       int empty,full,vol;//空的 和 满的 实际的
       int n;//表示各种硬币
       int value[50005],w[50005],dp[50005];
       while(t--)
       {
           cin>>empty>>full;
           cin>>n;
           for(int ii=1;ii<=n;ii++)
           {
               cin>>value[ii];
               cin>>w[ii];
           }
           vol=full-empty;
    
           for(int iii=1;iii<=vol;iii++)
           {
               dp[iii]=1000000001;
           }
            dp[0]=0;//除了dp 0 以外 其它的全部都为无穷大
    
           for(int i=1;i<=n;i++)
           {
               for(int j=w[i];j<=vol;j++)
               {
                   dp[j]=min(dp[j],dp[j-w[i]]+value[i]);
               }
           }
    
           if(dp[vol]<1000000001)
           {
               cout<<"The minimum amount of money in the piggy-bank is "<<dp[vol]<<"."<<endl;
           }
           else
           {
               cout<<"This is impossible."<<endl;
           }
    
    
    
       }
       return 0;
    }
  • 相关阅读:
    php 使用函数中遇到的坑之----list
    redis info
    Redis查询当前库有多少个 key
    Git怎样撤销一次分支的合并Merge
    JKS转PFX
    js获取当前域名、Url、相对路径和参数以及指定参数
    MySQL触发器更新和插入操作
    MySQL创建触发器的时候报1419错误( 1419
    xml 3 字节的 UTF-8 序列的字节 3 无效
    PostgreSQL的递归查询(with recursive) ,替代oracle 的级联查询connect by
  • 原文地址:https://www.cnblogs.com/William-xh/p/7339714.html
Copyright © 2011-2022 走看看