zoukankan      html  css  js  c++  java
  • hdu 1301 prime算法

     最小生成树prime算法

    Jungle Roads

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 7013    Accepted Submission(s): 5121


    Problem Description

    The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

    The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

    The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.
     

     

    Sample Input
    9 A 2 B 12 I 25 B 3 C 10 H 40 I 8 C 2 D 18 G 55 D 1 E 44 E 2 F 60 G 38 F 0 G 1 H 35 H 1 I 35 3 A 2 B 10 C 40 B 1 C 20 0
     

     

    Sample Output
    216 30
     
    题意:给定村庄数n,用字母表的前n个字母表示,接下来n-1行每行一个村庄字母和与其连接的村庄数以及各村庄的字母和距离。求最小生成树。
    典型的最小生成树,用了prime实现,0ms,1A
     
    #include<iostream>
    #define inf 999999
    
    using namespace std;
    
    int n,val,s;
    char mm,tt;
    struct myedge
    {
        int st,en,cost;
    }edge[27];
    int num[27][27];
    
    int prime()
    {
        int sum=0;
        for(int i = 0; i < n-1; i++)
        {
            edge[i].st=0;
            edge[i].en=i+1;
            edge[i].cost=num[0][i+1];
        }
        int k=0,t=0,minn;
        myedge e;
        while(k<n-1)
        {
            t=k;
            minn=edge[k].cost;
            for(int i = k+1; i < n-1; i++)
            {
                if(edge[i].cost<minn)
                {
                    minn=edge[i].cost;
                    t=i;
                }
            }
            e=edge[t];
            edge[t]=edge[k];
            edge[k]=e;
            k++;
            for(int i = k; i < n-1; i++)
            {
                if(num[e.en][edge[i].en]<edge[i].cost)
                {
                    edge[i].st=e.en;
                    edge[i].cost=num[e.en][edge[i].en];
                }
            }
        }
        for(int i = 0; i < n-1; i++)
        {
            sum+=edge[i].cost;
        }
        return sum;
    }
    int main()
    {
        cin.sync_with_stdio(false);
        while(cin>>n,n)
        {
            for(int i = 0; i <27; i++)
                for(int j = 0; j < 27; j++)
                    num[i][j]=inf;
            for(int i = 0; i < n-1; i++)
            {
                cin>>mm>>s;
                for(int j = 0; j < s; j++)
                {
                    cin>>tt>>val;
                    if(num[mm-'A'][tt-'A']>val)
                    {
                        num[mm-'A'][tt-'A']=val;
                        num[tt-'A'][mm-'A']=val;
                    }
    
                }
            }
            cout<<prime()<<endl;
        }
        return 0;
    }
  • 相关阅读:
    2017年8月21日 星期一 --出埃及记 Exodus 28:43
    2017年8月20日 星期日 --出埃及记 Exodus 28:42
    2017年8月19日 星期六 --出埃及记 Exodus 28:41
    2017年8月18日 星期五 --出埃及记 Exodus 28:40
    2017年8月17日 星期四 --出埃及记 Exodus 28:39
    2017年8月16日 星期三 --出埃及记 Exodus 28:38
    2017年8月15日 星期二 --出埃及记 Exodus 28:37
    2017年8月14日 星期一 --出埃及记 Exodus 28:36
    2017年8月13日 星期日 --出埃及记 Exodus 28:35
    2017年8月12日 星期六 --出埃及记 Exodus 28:34
  • 原文地址:https://www.cnblogs.com/Xycdada/p/6075965.html
Copyright © 2011-2022 走看看