zoukankan      html  css  js  c++  java
  • A1042. Shuffling Machine

    题目描述

      Shuffling is a procedure used to randomize da deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where

    employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines.

    Your task is to simulate a shuffling machine.

      The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is

    in the following order: S1, S2, ..., S13, H1, H2,..., H13, C1, C2, ..., C13, D1, D2, ..., D13, J1, J2

      where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]

    If the number at the i-thposition is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2.

    Given a shuffluing order {4, 2, 5, 3, 1}, the result will be : J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

    输入格式

      Each input file contanins one test case. For each case, the first line contains a positive interger K(≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

    输出格式

      For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

    输入样例

      2

      36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 46 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

    输出样例

      S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6  H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8   C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

    题意

    混洗是用于随机分配扑克牌的过程。因为标准混洗技术被认为是薄弱的,并且为了避免“内部工作”,员工通过进行不充分的洗牌与赌徒合作,许多赌场都使用自动洗牌机。

    您的任务是模拟混洗机。

    机器会根据给定的随机顺序随机播放54张卡片,并重复给定的次数。

    假设卡片组的初始状态为,按以下顺序:S1,S2,...,S13,H1,H2,...,H13,C1,C2,...,C13,D1,D2,...,D13,J1,J2

    其中“ S”代表“黑桃”,“ H”代表“红桃”,“ C”代表“梅花”,“ D”代表“钻石”,“ J”代表“小丑”。给定的顺序是[1,54]中不同整数的排列
    如果第i个位置的数字为j,则意味着将卡从位置i移动到位置j。

    例如,假设我们只有5张卡:S3,H5,C1,D13和J2,给定该组顺序{4,2,5,3,1},结果将为:J2,H5,D13,S3,C1。

    如果我们要再次重复洗牌,结果将是:C1,H5,S3,J2,D13

    基本思路

    • 给定的顺序的数组,下标是扑克牌初始位置,元素值是扑克牌最终位置
    • 每个牌用数字编号记录
    • 使用 start 数组记录每个牌的初始位置,使用next数组,记录每个牌的下一个位置,使用 end 数组更新牌的位置
    • 重复上述步骤,循环K次
    • 牌的花色对13取整得到,每个花色对应的牌的编号对13取余得到
    #include <bits/stdc++.h>
    int const N = 54;// 总牌数
    char mp [5] = {'S', 'H', 'C', 'D', 'J'};// 牌的花色 
    int start[N + 1], end[N + 1], next[N + 1];
    
    int main(int argc, char *argv[]) {
        int K;    
        scanf("%d", &K);// 洗牌的重复次数
        for(int i = 1; i <= N; i++){
            start[i] = i;// 初始化牌的编号         
        } 
        for(int i = 1;i <= N; i++){
            scanf("%d", &next[i]);// 输入每个位置上的牌在操作后的位置 
        }
        for(int step = 0; step < K; step++){// 洗牌K次 
            for(int i = 1; i <= N; i++){
                end[next[i]] = start[i];// 把第i个位置上的牌存于end数组中,对应位置为next[i]
            }
            for(int i = 1; i <= N; i++){
                start[i] = end[i];
            }
        }
        for(int i = 1; i <= N; i++){
            if(i != 1){
                printf(" ");
                start[i]--;
                printf("%c%d", mp[start[i]/13], start[i]%13 + 1);
            } 
        }
        return 0;    
    }

    题解关键

    • 注意牌的编号是从1还是从0开始
  • 相关阅读:
    bit、byte、word的区别
    JavaScript
    品牌的意义
    Java开发
    Java:关于implements Serializable的警告问题
    文件路径:/和的区别
    Iterator
    parameter和argument的区别
    Java中private、protected、public和default的区别
    Java异常
  • 原文地址:https://www.cnblogs.com/YC-L/p/12128416.html
Copyright © 2011-2022 走看看