zoukankan      html  css  js  c++  java
  • HDU

    题面

    Ted is a employee of Always Cook Mushroom (ACM). His boss Matt gives him a pack of mushrooms and ask him to grade each mushroom according to its weight. Suppose the weight of a mushroom is w, then it’s grade s ({s = 10000 - (100 - w)^2})

    What’s more, Ted also has to report the mode of the grade of these mushrooms. The mode is the value that appears most often. Mode may not be unique. If not all the value are the same but the frequencies of them are the same, there is no mode.
    InputThe first line of the input contains an integer T, denoting the number of testcases. Then T test cases follow.

    The first line of each test cases contains one integers N (1<=N<=10^6),denoting the number of the mushroom.

    The second line contains N integers, denoting the weight of each mushroom. The weight is greater than 0, and less than 200. OutputFor each test case, output 2 lines.

    The first line contains "Case #x:", where x is the case number (starting from 1)

    The second line contains the mode of the grade of the given mushrooms. If there exists multiple modes, output them in ascending order. If there exists no mode, output “Bad Mushroom”.

    Sample Input

    3
    6
    100 100 100 99 98 101
    6
    100 100 100 99 99 101
    6
    100 100 98 99 99 97
    

    Sample Output

    Case #1:
    10000
    Case #2:
    Bad Mushroom
    Case #3:
    9999 10000
    

    思路/题意

    给出n个蘑菇的重量,根据重量计算出蘑菇的分数,按照大小输出分数最多的分数。如果分数包含了所有的蘑菇,除非只有一种分数,否则输出Bad Mushroom.

    代码

    #include <bits/stdc++.h>
    using namespace std;
    const int maxn = 1e6 + 100;
    map<int, int> mp;
    vector<int> ans;
    int main()
    {
        ios::sync_with_stdio(0);
        cin.tie(0);
        cout.tie(0);
    #ifndef ONLINE_JUDGE
        freopen("in.txt", "r", stdin);
        freopen("out.txt", "w", stdout);
    #endif
        int T;
        cin >> T;
        for (int tt = 1; tt <= T; ++tt)
        {
            mp.clear();
            ans.clear();
            cout << "Case #" << tt << ":" << endl;
            int maxx = 0;
            int n; cin >> n;
            for (int i = 0; i < n; ++i)
            {
                int tmp;
                cin >> tmp;
                tmp = 10000 - (100 - tmp) * (100 - tmp);
                mp[tmp] = mp[tmp] + 1;
                maxx = max(maxx, mp[tmp]);
            }
    
            for (map<int, int>::iterator it = mp.begin(); it != mp.end(); ++it)
            {
                if (it->second == maxx)
                    ans.push_back(it->first);
            }
    
            if (maxx * ans.size() == n && ans.size() > 1)
                cout << "Bad Mushroom" << endl;
            else
            {
                for (int i = 0; i < ans.size(); ++i)
                {
                    if (i != 0)
                        cout << " ";
                    cout << ans[i];
                }
                cout << endl;
            }
        }
        return 0;
    }
    
  • 相关阅读:
    golang生成树状菜单
    golang自定义某种类型时的打印输出
    【转】搭建自己的邮件服务器
    【转】【VSCode】golang的调试配置launch.json
    【转】Nvidia GeForce MX250 Lower-End Dedicated Graphics
    【转】Alertmanager高可用
    【转】Prometheus 和 Alertmanager实战配置
    YAML格式的语法
    golang写一个占用大内存的程序
    [转]TDengine常用命令及SQL
  • 原文地址:https://www.cnblogs.com/YY666/p/11537441.html
Copyright © 2011-2022 走看看