zoukankan      html  css  js  c++  java
  • Sliding Window

    Description

    An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:
    The array is [1 3 -1 -3 5 3 6 7], and k is 3.
    在这里插入图片描述

    Your task is to determine the maximum and minimum values in the sliding window at each position.

    Input

    The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.
    Output

    There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.

    Sample Input
    8 3
    1 3 -1 -3 5 3 6 7

    Sample Output
    -1 -3 -3 -3 3 3
    3 3 5 5 6 7

    .
    .
    .
    .
    .
    分析
    单调队列即可
    注意m=1的情况

    .
    .
    .
    .
    .
    程序:

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    using namespace std;
    
    int a[1000010],q[1000010],n,m,p[1000010];
    
    void zx()
    {
    	int head=1,tail=1;
    	q[head]=1;
    	if (m==1) printf("%d ",a[q[head]]);
    	for (int i=2;i<=n;i++)
    	{
    		while (head<=tail&&a[q[tail]]>=a[i]) tail--;
    		tail++;
    		q[tail]=i;
    		while (i-q[head]+1>m) head++;
    		if (i>=m) printf("%d ",a[q[head]]);
    	}
    }
    
    void zd()
    {
    	int head=1,tail=1;
    	p[head]=1;
    	if (m==1) printf("%d ",a[p[head]]);
    	for (int i=2;i<=n;i++)
    	{
    		while (head<=tail&&a[p[tail]]<=a[i]) tail--;
    		tail++;
    		p[tail]=i;
    		while (i-p[head]+1>m) head++;
    		if (i>=m) printf("%d ",a[p[head]]);
    	}
    }
    
    int main()
    {
    	scanf("%d%d",&n,&m);
    	for (int i=1;i<=n;i++)
    		scanf("%d",&a[i]);
    	zx();
    	cout<<endl;
    	zd();
    	return 0;
    }
    
  • 相关阅读:
    kubernetes 二进制安装v2
    Istio
    linux的history指令显示时间
    echarts折线图y轴刻度值按照某个值的倍数
    ubuntu下tesseract 4.0安装及参数使用
    chrome 浏览器下载大文件断掉的问题
    强化学习
    第十一篇 -- 2020总结以及2021期待
    字符串时间yyyyMMddHHmmss转成yyyy-MM-dd HH-mm-ss字符串格式
    windows安装mongodb,密码访问
  • 原文地址:https://www.cnblogs.com/YYC-0304/p/10292788.html
Copyright © 2011-2022 走看看