zoukankan      html  css  js  c++  java
  • Treasure Exploration

    Description

    Have you ever read any book about treasure exploration? Have you ever see any film about treasure exploration? Have you ever explored treasure? If you never have such experiences, you would never know what fun treasure exploring brings to you.
    Recently, a company named EUC (Exploring the Unknown Company) plan to explore an unknown place on Mars, which is considered full of treasure. For fast development of technology and bad environment for human beings, EUC sends some robots to explore the treasure.
    To make it easy, we use a graph, which is formed by N points (these N points are numbered from 1 to N), to represent the places to be explored. And some points are connected by one-way road, which means that, through the road, a robot can only move from one end to the other end, but cannot move back. For some unknown reasons, there is no circle in this graph. The robots can be sent to any point from Earth by rockets. After landing, the robot can visit some points through the roads, and it can choose some points, which are on its roads, to explore. You should notice that the roads of two different robots may contain some same point.
    For financial reason, EUC wants to use minimal number of robots to explore all the points on Mars.
    As an ICPCer, who has excellent programming skill, can your help EUC?
    Input

    The input will consist of several test cases. For each test case, two integers N (1 <= N <= 500) and M (0 <= M <= 5000) are given in the first line, indicating the number of points and the number of one-way roads in the graph respectively. Each of the following M lines contains two different integers A and B, indicating there is a one-way from A to B (0 < A, B <= N). The input is terminated by a single line with two zeros.
    Output

    For each test of the input, print a line containing the least robots needed.
    Sample Input

    1 0
    2 1
    1 2
    2 0
    0 0
    Sample Output

    1
    1
    2

    .
    .
    .
    .
    .
    分析
    先用floyd求出原图的传递闭包,即如果a到b有路径,那么就加边a->b。然后就转化成了最小不相交路径覆盖问题。

    .
    .
    .
    .
    .
    程序:

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    using namespace std;
    int ans,tj,n,m,link[510],v[510];
    bool d[510][510];
    
    int find(int k)
    {
    	for (int i=1;i<=n;i++)
    	{
    		if (!v[i]&&d[k][i]==true)
    		{
    			v[i]=1;
    			if (!link[i]||find(link[i]))
    			{
    				link[i]=k;
    				return 1;
    			}
    		}
    	}
    	return 0;
    }
    
    int main()
    {
    	while (scanf("%d%d",&n,&m))
    	{
    		if (n==0&&m==0) break;
    		int tj=0;
    		
    		memset(d,false,sizeof(d));
    		for (int i=1;i<=m;i++)
    		{
    			int x,y;
    			scanf("%d%d",&x,&y);
    			d[x][y]=true;
    			
    		}
    		
    		for (int k=1;k<=n;k++)
    			for (int i=1;i<=n;i++)
    				 for (int j=1;j<=n;j++)
    				 	if (d[i][k]==true&&d[k][j]==true) d[i][j]=true;
    		
    		int ans=0;
    		memset(link,0,sizeof(link));
    		for (int i=1;i<=n;i++)
    		{
    			memset(v,0,sizeof(v));
    			if (find(i)) ans++;
    		}
    		
    		cout<<n-ans<<endl;
    	}
    	return 0;
    }
    
  • 相关阅读:
    QSet<T>自定义类型需要定义==和qHash()函数
    《左耳听风》-ARTS-打卡记录-第十三周
    Windows中对窗口进行剪切
    Markdown 编写规范
    【洛谷 P1033】自由落体
    【GOJ 3032】司愁之路
    动态规划基础 3-解题报告
    前缀、中缀、后缀互相转换
    【GOJ 3015】疯狂外星人
    【GOJ 3010】有趣的数
  • 原文地址:https://www.cnblogs.com/YYC-0304/p/10292796.html
Copyright © 2011-2022 走看看