zoukankan      html  css  js  c++  java
  • 杭电OJ2004——成绩转换

    /*
    成绩转换
    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 140424    Accepted Submission(s): 61308


    Problem Description
    输入一个百分制的成绩t,将其转换成对应的等级,具体转换规则如下:
    90~100为A;
    80~89为B;
    70~79为C;
    60~69为D;
    0~59为E;
     

    Input
    输入数据有多组,每组占一行,由一个整数组成。
     

    Output
    对于每组输入数据,输出一行。如果输入数据不在0~100范围内,请输出一行:“Score is error!”。
     

    Sample Input

    56
    67
    100
    123

     

    Sample Output

    E
    D
    A
    Score is error!
    */

    #include <stdio.h>
    int main(void)
    {
        int t = 0;
        while(scanf("%d",&t) != EOF)
        {
            if(t > 100 || t < 0)
                printf("Score is error! ");
            else if(t <= 59)
                printf("E ");
            else if(t <= 69)
                printf("D ");
            else if(t <= 79)
                printf("C ");
            else if(t <= 89)
                printf("B ");
            else if(t <= 100)
                printf("A ");
        }
        return 0;
    }

  • 相关阅读:
    K8S 之Pod简单提供持久化存储
    K8S 备份所有Namespace的yaml应用配置文件
    Ceph 集群部署
    Django cookie使用
    Django CBV使用
    hashlib模块
    如何序列化之json和pickle:
    os模块
    random模块
    os模块
  • 原文地址:https://www.cnblogs.com/YaLi/p/6475266.html
Copyright © 2011-2022 走看看