zoukankan      html  css  js  c++  java
  • POJ 2579 Fiber Network(状态压缩+Floyd)

    Fiber Network
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 3328   Accepted: 1532

    Description

    Several startup companies have decided to build a better Internet, called the "FiberNet". They have already installed many nodes that act as routers all around the world. Unfortunately, they started to quarrel about the connecting lines, and ended up with every company laying its own set of cables between some of the nodes.
    Now, service providers, who want to send data from node A to node B are curious, which company is able to provide the necessary connections. Help the providers by answering their queries.

    Input

    The input contains several test cases. Each test case starts with the number of nodes of the network n. Input is terminated by n=0. Otherwise, 1<=n<=200. Nodes have the numbers 1, ..., n. Then follows a list of connections. Every connection starts with two numbers A, B. The list of connections is terminated by A=B=0. Otherwise, 1<=A,B<=n, and they denote the start and the endpoint of the unidirectional connection, respectively. For every connection, the two nodes are followed by the companies that have a connection from node A to node B. A company is identified by a lower-case letter. The set of companies having a connection is just a word composed of lower-case letters.
    After the list of connections, each test case is completed by a list of queries. Each query consists of two numbers A, B. The list (and with it the test case) is terminated by A=B=0. Otherwise, 1<=A,B<=n, and they denote the start and the endpoint of the query. You may assume that no connection and no query contains identical start and end nodes.

    Output

    For each query in every test case generate a line containing the identifiers of all the companies, that can route data packages on their own connections from the start node to the end node of the query. If there are no companies, output "-" instead. Output a blank line after each test case.

    Sample Input

    3
    1 2 abc
    2 3 ad
    1 3 b
    3 1 de
    0 0
    1 3
    2 1
    3 2
    0 0
    2
    1 2 z
    0 0
    1 2
    2 1
    0 0
    0
    

    Sample Output

    ab
    d
    -
    
    z
    -
    

    Source

    题意:从起点到终点找到所有边权上的相同的地方。
    思路: 首先,由于边权是字母又是要求边权上的相同的地方,想到状态压缩。且具有传递性,就用Floyd.
    收获:a[u][v] |= 1<<(s[i] - 'a');中的|=是存入状态。a[i][k] & a[k][j] 中的&是来判断有相同的地方。
    #include <cstdio>
    #include <iostream>
    #include <cstdlib>
    #include <algorithm>
    #include <ctime>
    #include <cmath>
    #include <string>
    #include <cstring>
    #include <stack>
    #include <queue>
    #include <list>
    #include <vector>
    #include <map>
    #include <set>
    using namespace std;
    
    const int INF = 0x3f3f3f3f;
    const double eps = 1e-10;
    const double PI = acos(-1.0);
    
    const int maxn = 500;
    int a[maxn][maxn];
    int main()
    {
        int n;
        while(~scanf("%d", &n)&&n)
        {
            int u, v;
            memset(a, 0, sizeof(a));
            while(scanf("%d%d", &u, &v)&& (u+v))
            {
                char s[100];
                scanf("%s", s);
                for(int i = 0; i < strlen(s); i++)
                    a[u][v] |= 1<<(s[i] - 'a');
            }
    
            for(int k = 1; k <= n; k++)
                for(int i = 1; i <= n; i++)
                    for(int j = 1; j <= n; j++)
                    a[i][j] |= a[i][k] & a[k][j];
    
            while(scanf("%d%d", &u, &v) && (u+v))
            {
                    for(int i = 'a'; i <= 'z'; i++)
                         if(a[u][v] & (1 << (i-'a')))
                         printf("%c",i);
                    if(!a[u][v])
                        printf("%c",'-');
                    puts("");
            }
            puts("");
        }
        return 0;
    }
     
  • 相关阅读:
    ckplayer不支持谷歌92版本,flashplayer不支持m3u8的方案
    git merge 失败
    在SuperSocket中使用Unity注入
    在WPF中集成SuperSocket 2.0
    在WPF中打印A4纸
    使用 HoloLens 仿真器
    C# 优化内存和运行效率
    Redis 高可用篇:你管这叫 Sentinel 哨兵集群原理
    Redis 核心篇:唯快不破的秘密
    Redis 日志篇:无畏宕机快速恢复的杀手锏
  • 原文地址:https://www.cnblogs.com/ZP-Better/p/4714764.html
Copyright © 2011-2022 走看看