zoukankan      html  css  js  c++  java
  • HDU4762(JAVA大数)

    Cut the Cake

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 1102    Accepted Submission(s): 540


    Problem Description
    MMM got a big big big cake, and invited all her M friends to eat the cake together. Surprisingly one of her friends HZ took some (N) strawberries which MMM likes very much to decorate the cake (of course they also eat strawberries, not just for decoration). HZ is in charge of the decoration, and he thinks that it's not a big deal that he put the strawberries on the cake randomly one by one. After that, MMM would cut the cake into M pieces of sector with equal size and shape (the last one came to the party will have no cake to eat), and choose one piece first. MMM wants to know the probability that she can get all N strawberries, can you help her? As the cake is so big, all strawberries on it could be treat as points.
     
    Input
    First line is the integer T, which means there are T cases.
    For each case, two integers M, N indicate the number of her friends and the number of strawberry.
    (2 < M, N <= 20, T <= 400)
     
    Output
    As the probability could be very small, you should output the probability in the form of a fraction in lowest terms. For each case, output the probability in a single line. Please see the sample for more details.
     
    Sample Input
    2 3 3 3 4
     
    Sample Output
    1/3 4/27
    题意:切M块蛋糕,求N个草莓全部在一块蛋糕上的概率。
    公式:n/(m的n-1次方);
    收获:了解了下JAVA大数。化简可以用两个数的最小公倍数。
    import java.math.*;
    import java.util.*;
    public class Main {
    
        public static void main(String[] args) {
            // TODO Auto-generated method stub
            Scanner in = new Scanner(System.in);
            int t = in.nextInt();
            while(t-->0)
            {
                BigInteger m = in.nextBigInteger();
                int n = in.nextInt();
                m=m.pow(n-1); 
                BigInteger b=BigInteger.valueOf(n);
                BigInteger a;
                a = m.gcd(b);
                BigInteger c = m.divide(a);
                BigInteger c2 = b.divide(a);
                System.out.println(c2 + "/" + c);
            }
    
        }
    
    }
  • 相关阅读:
    java 支付宝即时到帐提交订单dome
    C#字符串string的常用使用方法(转载)
    UltraEdit 回车符替换空格
    java 七牛上传图片到服务器(采用的html5 压缩 传输base64方式)
    c# 多播委托
    c# 泛型委托
    c# 求数组的最大值
    c# 匿名函数和lamda表达式语法
    匿名函数和lamda表达式
    导出Excel之Epplus使用教程4(其他设置)
  • 原文地址:https://www.cnblogs.com/ZP-Better/p/4734338.html
Copyright © 2011-2022 走看看