zoukankan      html  css  js  c++  java
  • pat 甲级 1053. Path of Equal Weight (30)

    1053. Path of Equal Weight (30)

    时间限制
    100 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

    Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.


    Figure 1

    Input Specification:

    Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

    ID K ID[1] ID[2] ... ID[K]
    

    where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

    Output Specification:

    For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

    Note: sequence {A1, A2, ..., An} is said to be greater than sequence {B1, B2, ..., Bm} if there exists 1 <= k < min{n, m} such that Ai = Bifor i=1, ... k, and Ak+1 > Bk+1.

    Sample Input:
    20 9 24
    10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
    00 4 01 02 03 04
    02 1 05
    04 2 06 07
    03 3 11 12 13
    06 1 09
    07 2 08 10
    16 1 15
    13 3 14 16 17
    17 2 18 19
    
    Sample Output:
    10 5 2 7
    10 4 10
    10 3 3 6 2
    10 3 3 6 2

    题意:寻找所有节点键值的和为指定值的路径,并且按照一定规则对路径排序后输出。
    思路:dfs
    AC代码:
    #define _CRT_SECURE_NO_DEPRECATE
    #include<iostream>
    #include<algorithm>
    #include<cmath>
    #include<cstring>
    #include<string>
    #include<set>
    #include<queue>
    #include<map>
    using namespace std;
    #define INF 0x3f3f3f
    #define N_MAX 100+5
    typedef long long ll;
    int n, m, sum;
    struct Node {
        int key,id;
        Node() {}
        Node(int id,int key):id(id),key(key) {}
    }node[N_MAX];
    vector<Node>G[N_MAX];
    
    int road[N_MAX];
    vector<vector<int> >r; 
    vector<int>tmp;
    void dfs(int x,int step,int add) {
        road[step] = node[x].key;
        if (G[x].size() == 0 &&add==sum) {//符合条件
            tmp.clear();
            for (int i = 0; i <=step; i++)tmp.push_back(road[i]);
            r.push_back(tmp);
            return;
        }
        for (int i = 0; i < G[x].size();i++) {
            Node p = G[x][i];
            dfs(p.id, step + 1, p.key + add);
        }
    }
    
    bool cmp(vector<int>a,vector<int>b ) {
        int i = 0;
        while (a[i] == b[i]&&i<a.size()-1&&i<b.size()-1)i++;
        return   a[i] > b[i];
    }
    
    
    int main() {
        while (cin>>n>>m>>sum) {
            for (int i = 0; i < n; i++) {
                int  a; cin >> a;
                node[i] = Node(i, a);
            }
            for (int i = 0; i < m;i++) {
                int from, k;
                cin >> from >> k;
                while (k--) {
                    int to; cin >> to;
                    G[from].push_back(node[to]);
                }
            }
            dfs(0, 0, node[0].key);
            sort(r.begin(), r.end(), cmp);
            for (int i = 0; i < r.size();i++) {
                for (int j = 0; j < r[i].size();j++) {
                    printf("%d%c",r[i][j],j+1==r[i].size()?'
    ':' ');
                }
            }
        }
        return 0;
    }
  • 相关阅读:
    Linux基础(Ubuntu16.04):安装vim及配置
    Ubuntu16.04 安装ROS及其IDE
    python格式转换的记录
    python爬虫selenium相关
    【LAMP】搭建Web网站过程中的记录【Ubuntu18.04+Apache2.4+PHP7.2+MySQL5.7】
    【疯狂挖坑】linux服务器尝试中的问题(nohup等)
    逻辑回归与全连接神经网络联系的简单理解记录
    Unity3d开发中遇到的问题记录
    python中numpy库的一些使用
    Deep Learning论文翻译(Nature Deep Review)
  • 原文地址:https://www.cnblogs.com/ZefengYao/p/8561328.html
Copyright © 2011-2022 走看看