zoukankan      html  css  js  c++  java
  • 数据结构练习 00-自测5. Shuffling Machine (20)

    Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

    The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

    S1, S2, ..., S13, H1, H2, ..., H13, C1, C2, ..., C13, D1, D2, ..., D13, J1, J2

    where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer K (<= 20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

    Sample Input:

    2
    36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47
    

    Sample Output:

    S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5
    
    #include<iostream>
    #include<string>
    using namespace std;
    int main(){
        string a[55],b[55];
        char temp[2];
        int c[55],times;
        cin>>times;
        for(int i=1;i<55;i++){
            cin>>c[i];
        }
        for(int i=1;i<53;i++){
            if(i<=13){
                sprintf(temp,"%d",i);
                string s(temp);
                a[i]="S"+s;
            }else if(i<=13+13){
                sprintf(temp,"%d",i-13);
                string s(temp);
                a[i]="H"+s;
            }else if(i<=13+13+13){
                sprintf(temp,"%d",i-13-13);
                string s(temp);
                a[i]="C"+s;
            }else if(i<=13+13+13+13){
                sprintf(temp,"%d",i-13-13-13);
                string s(temp);
                a[i]="D"+s;
            }
        }
        a[53]="J1";
        a[54]="J2";
        for(int j=1;j<=times;j++){
            for(int i=1;i<=54;i++){
                b[c[i]]=a[i];
            }
            for(int i=1;i<=54;i++){
                a[i]=b[i];
            }
        }
        for(int i=1;i<=54;i++){
            if(i==54){
                cout<<a[i];
            }else{
                cout<<a[i]<<" ";
            }    
            
        }
        return 0;
    }

    image

  • 相关阅读:
    Lodop实现web套打
    oracle监听文件 内容
    【数据存储】【Redis】第四章:高并发下实现分布式锁
    Demo:第二章:Java实现随机图像生成(人像,汽车,房屋等等)
    【数据存储】【Redis】第五章:Redis缓存String类型的使用场景
    【数据存储】【Redis】第三章: Redis五大数据类型实现原理
    【Java面试】:第三章:P6级面试
    【数据存储】【Redis】第二章:底层数据结构
    实战:第二十二章:i18n国际化(已实现中文,英文,波兰文)
    Demo:第三章:权限框架spring security oauth2
  • 原文地址:https://www.cnblogs.com/Zengineer/p/4315803.html
Copyright © 2011-2022 走看看