zoukankan      html  css  js  c++  java
  • 数据结构练习 02-线性结构3. Pop Sequence (25)

    Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

    Output Specification:

    For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

    Sample Input:

    5 7 5
    1 2 3 4 5 6 7
    3 2 1 7 5 6 4
    7 6 5 4 3 2 1
    5 6 4 3 7 2 1
    1 7 6 5 4 3 2
    

    Sample Output:

    YES
    NO
    NO
    YES
    NO
    #include<iostream>  
    #include<stack>  
    using namespace std;
    
    int main()
    {
        int M; //maximum capacity of the stack  
        int N; //the length of push sequence  
        int K; //the number of pop sequence to be checked  
        cin >> M >> N >> K;
        int i, j;
        int input, temp;
        bool flag = true;
        stack<int> sta;
    
        for (i = 0; i < K; i++)
        {
            temp = 1;
            flag = true;
            for (j = 0; j < N; j++)
            {
                cin >> input;
                while (sta.size() <= M && flag)
                {
                    if (sta.empty() || sta.top() != input)
                    {
                        sta.push(temp++);
                    }
                    else if (sta.top() == input)
                    {
                        sta.pop();
                        break;
                    }
                }
                if (sta.size() > M)
                {
                    flag = false;
                }
            }
    
            if (flag)
                cout << "YES" << endl;
            else
                cout << "NO" << endl;
            while (!sta.empty())
                sta.pop();
        }
        return 0;
    }

  • 相关阅读:
    ($children,$refs,$parent)的使用
    watch监听变化
    vue组件间通信六种方式(完整版)
    CSS水平垂直居中常见方法总结2
    CSS水平垂直居中常见方法总结
    Uncaught SyntaxError: Unexpected identifier 报错 import Vue from 'vue';
    前端跳槽面试必备
    防止重复发送Ajax请求问题
    JQuery中的$().each 以及 $.each的区别
    数组中的forEach和map的区别
  • 原文地址:https://www.cnblogs.com/Zengineer/p/4538191.html
Copyright © 2011-2022 走看看