zoukankan      html  css  js  c++  java
  • (多重背包)poj 1276

    Cash Machine
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 28364   Accepted: 10125

    Description

    A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

    N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

    means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

    Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

    Notes: 
    @ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

    Input

    The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

    cash N n1 D1 n2 D2 ... nN DN 

    where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

    Output

    For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

    Sample Input

    735 3  4 125  6 5  3 350
    633 4  500 30  6 100  1 5  0 1
    735 0
    0 3  10 100  10 50  10 10

    Sample Output

    735
    630
    0
    0

    Hint

    The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash. 

    In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash. 

    In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

    Source

    加了一个计数器而已

    #include <iostream>
    
    using namespace std;
    
    #define MAXN 10
    #define MAXCASH 100000
    
    int main() {
    	int i, j;
    	int N;
    	int cash;
    	while (cin >> cash >> N) {
    		int n[MAXN + 1], w[MAXN + 1], c[MAXN + 1], dp[MAXCASH + 1], count[MAXCASH + 1];
            
    		for (i = 1; i <= N; i++) {
    			cin >> n[i] >> w[i];
    			c[i] = w[i];
    		}
            
    		memset(dp, 0, sizeof(dp));
    		for (i = 1; i <= N; i++) {
    			memset(count, 0, sizeof(count));
    			for (j = w[i]; j <= cash; j++)
    				if (dp[j] < dp[j - c[i]] + w[i] && count[j - c[i]] < n[i]) {
    					dp[j] = dp[j - c[i]] + w[i];
    					count[j] = count[j - c[i]] + 1;
    				}
    		}
    		cout << dp[cash] << endl;
    	}
    }
    

      

  • 相关阅读:
    Maven简介,安装,配置
    Centos 安装 Tomcat 并验证
    Centos 安装 jdk 和配置环境变量
    java基本数据类型
    centos7中docker安装并启动jpress
    在docker中访问网络
    在docker中运行一个nginx
    Centos7 安装docker 及使用其简单命令
    Centos7安装dnf工具管理rpm包
    C#获取外网IP地址;C#获取所在IP城市地址
  • 原文地址:https://www.cnblogs.com/a972290869/p/4246638.html
Copyright © 2011-2022 走看看