zoukankan      html  css  js  c++  java
  • POJ 1611 The Suspects

    Description

    Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
    In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
    Once a member in a group is a suspect, all members in the group are suspects. 
    However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

    Input

    The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
    A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

    Output

    For each case, output the number of suspects in one line.

    Sample Input

    100 4
    2 1 2
    5 10 13 11 12 14
    2 0 1
    2 99 2
    200 2
    1 5
    5 1 2 3 4 5
    1 0
    0 0

    Sample Output

    4
    1
    1


    题目大意,0号学生感染SARS,学校有很多团体,如果0号学生在某团体,则这个团体都感染,并且这个团体的成员所在其他团体也会感染,并扩散,问最后有多少人会感染SARS。
    解题思路:
    并查集。

    package poj.unionfind;
    
    import java.util.Scanner;
    
    /**
     * Created by blank on 2015-10-16 上午10:15.
     */
    public class _1611 {
        public static void main(String[] args) {
            Scanner sc = new Scanner(System.in);
            while (true) {
                int n = sc.nextInt();
                int m = sc.nextInt();
                if (n == 0 && m == 0) {
                    return;
                }
                if (n == 1) {
                    System.out.println(1);
                    continue;
                }
                WUF uf = new WUF(n);
                while (m-- > 0) {
                    int k = sc.nextInt();
                    int s1 = sc.nextInt();
                    while (--k > 0) {
                        int s2 = sc.nextInt();
                        uf.union(s1, s2);
                        s1 = s2;
                    }
                }
                System.out.println(uf.getSARS(0));
            }
        }
    
        static class WUF {
            int[] parent;
            int[] num;
            byte[] rank;
            int len;
    
            public WUF(int n) {
                parent = new int[n];
                num = new int[n];
                rank = new byte[n];
                for (int i = 0; i < n; i++) {
                    parent[i] = i;
                    num[i] = 1;
                }
                this.len = n;
            }
    
            private int find(int p) {
                while (p != parent[p]) {
                    parent[p] = parent[parent[p]];
                    p = parent[p];
                }
                return p;
            }
    
            private void union(int p, int q) {
                int rootP = find(p);
                int rootQ = find(q);
                if (rootP == rootQ) {
                    return;
                }
                if (rank[rootP] < rank[rootQ]) {
                    parent[rootP] = rootQ;
                    num[rootQ] += num[rootP];
                } else {
                    parent[rootQ] = rootP;
                    if (rank[rootP] == rank[rootQ]) {
                        rank[rootP]++;
                    }
                    num[rootP] += num[rootQ];
                }
            }
    
    
            public int getSARS(int p) {
                int root = find(p);
                return num[root];
            }
        }
    }
  • 相关阅读:
    Java排序算法之归并排序
    Java多线程学习笔记(四)——Thread类中方法介绍
    大数据平台搭建:Hadoop
    np.arrange用法
    Pandas中DateFrame修改列名
    python .loc vs .iloc区别
    The categories of Reinforcement Learning 强化学习分类
    python3.6安装总结
    梯度下降法与牛顿下降法速度的比较
    My SQL 和SQL Server区别
  • 原文地址:https://www.cnblogs.com/aboutblank/p/4884647.html
Copyright © 2011-2022 走看看