zoukankan      html  css  js  c++  java
  • HDU 1069 Monkey and Banana(dp)

    HDU 1069 Monkey and Banana(dp)

    A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

    The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

    They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn’t be stacked.

    Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
    Input
    The input file will contain one or more test cases. The first line of each test case contains an integer n,
    representing the number of different blocks in the following data set. The maximum value for n is 30.
    Each of the next n lines contains three integers representing the values xi, yi and zi.
    Input is terminated by a value of zero (0) for n.
    Output
    For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format “Case case: maximum height = height”.
    Sample Input

    1
    10 20 30
    2
    6 8 10
    5 5 5
    7
    1 1 1
    2 2 2
    3 3 3
    4 4 4
    5 5 5
    6 6 6
    7 7 7
    5
    31 41 59
    26 53 58
    97 93 23
    84 62 64
    33 83 27
    0
    

    Sample Output

    Case 1: maximum height = 40
    Case 2: maximum height = 21
    Case 3: maximum height = 28
    Case 4: maximum height = 342
    

    最长递增子序列问题,一开始纠结于箱子怎么放,后来发现把三种不同方向的放法当成三个不同的箱子就行,然后对箱子底边大小进行排序后直接写就可以了

        #include <iostream>
        #include <algorithm>
        using namespace std;
        int n;
        struct block
        {
        int x,y,hight;
        int dp;
        }box[100];
        bool com(block a,block b)
        {
        if(a.x>b.x) return 1;
        else if(a.x==b.x&&a.y>b.y) return 1;
        else return 0;
        }
        int main()
        {
        int h=1;
        while (cin>>n)
        {
            if(n==0)
                break;
            int d[3];
            int k=0;
            for(int i=0;i<n;i++)
            {
                cin>>d[0]>>d[1]>>d[2];
                sort(d,d+3);
                box[k].x=d[2];box[k].y=d[1];box[k].hight=d[0];k++;
                box[k].x=d[2];box[k].y=d[0];box[k].hight=d[1];k++;
                box[k].x=d[1];box[k].y=d[0];box[k].hight=d[2];k++;
            }
            sort(box,box+k,com);
            for(int i=0;i<k;i++)
                box[i].dp=box[i].hight;
            int ans=0;
            for(int i=k-2;i>=0;i--)
            {
                for(int j=k-1;j>i;j--)
                    if(box[i].x>box[j].x&&box[i].y>box[j].y)
                    box[i].dp=max(box[i].dp,box[j].dp+box[i].hight);
                if(box[i].dp>ans)
                    ans=box[i].dp;
            }
            cout<<"Case "<<h<<": maximum height = "<<ans<<endl;
            h++;
        }
        return 0;
        }
  • 相关阅读:
    XML WebService完全实例详细解析
    List (Java 2 Platform SE 5.0)
    frameset
    关于在outlook2007里面编辑签名的问题
    关于javax.servlet.Http.*;不能被引用的问题
    select标签HTML,刚做地。
    UIButton中setTitleEdgeInsets和setImageEdgeInsets的使用
    玩转UICollectionViewLayout
    常用公共方法
    cell嵌套UIWebView遇到的几个问题
  • 原文地址:https://www.cnblogs.com/acagain/p/9180741.html
Copyright © 2011-2022 走看看