zoukankan      html  css  js  c++  java
  • 2018 徐州网络赛 H

    Ryuji is not a good student, and he doesn't want to study. But there are n books he should learn, each book has its knowledge a[i]a[i].

    Unfortunately, the longer he learns, the fewer he gets.

    That means, if he reads books from ll to rr, he will get a[l] imes L + a[l+1] imes (L-1) + cdots + a[r-1] imes 2 + a[r]a[l]×L+a[l+1]×(L1)++a[r1]×2+a[r] (LL is the length of [ ll, rr ] that equals to r - l + 1rl+1).

    Now Ryuji has qq questions, you should answer him:

    11. If the question type is 11, you should answer how much knowledge he will get after he reads books [ ll, rr ].

    22. If the question type is 22, Ryuji will change the ith book's knowledge to a new value.

    Input

    First line contains two integers nn and qq (nn, q le 100000q100000).

    The next line contains n integers represent a[i]( a[i] le 1e9)a[i](a[i]1e9) .

    Then in next qq line each line contains three integers aa, bb, cc, if a = 1a=1, it means question type is 11, and bb, ccrepresents [ ll , rr ]. if a = 2a=2 , it means question type is 22 , and bb, cc means Ryuji changes the bth book' knowledge to cc

    Output

    For each question, output one line with one integer represent the answer.

    样例输入

    5 3
    1 2 3 4 5
    1 1 3
    2 5 0
    1 4 5

    样例输出

    10
    8

    题目来源

    ACM-ICPC 2018 徐州赛区网络预赛

     

    思路:

    维护两个树状数组。

    #include <bits/stdc++.h>
    using namespace std;
    const int maxn=1e6+10;
    typedef long long ll;
    ll t1[maxn],t2[maxn],a[maxn];
    inline int lowbit(int x){return x&-x;}
    void update(int x,ll val,ll *tree){
        for (int i=x; i<maxn; i+=lowbit(i)) tree[i]+=val;
    }
    ll Query(int x,ll *tree){
        ll res=0;
        for (int i=x; i; i-=lowbit(i)) res+=tree[i];
        return res;
    }
    int n,q;
    int op,l,r;
    int main(){
        scanf("%d%d",&n,&q);
        for (int i=1; i<=n; i++) {
            scanf("%lld",&a[i]);
            update(i,a[i]*(n-i+1),t1);
            update(i,a[i],t2);
        }
    
        while(q--){
            scanf("%d",&op);
            if(op==1){
                scanf("%d%d",&l,&r);
                ll tmp=Query(r,t1)-Query(l-1,t1);
                tmp-=1ll*(Query(r,t2)-Query(l-1,t2))*(n-r);
                cout<<tmp<<endl;
            } else {
                scanf("%d%d",&l,&r);
                update(l,(r-a[l])*(n-l+1),t1);
                update(l,(r-a[l]),t2);
                a[l]=r;
            }
        }
        return 0;
    }
    View Code
  • 相关阅读:
    Java程序员之JS(一) 入门
    Java虚拟机(一)之开篇
    JDK/JRE/JVM区别与联系
    web开发视频(一)之环境准备
    Spring MVC 教程,快速入门,深入分析
    Java中“==和equals”的区别
    如何查看电脑最大支持多少GB内存
    win10 计算器calc命令打不开
    Win10图标显示不正常解决办法
    在系统右键菜单上添加程序
  • 原文地址:https://www.cnblogs.com/acerkoo/p/9638095.html
Copyright © 2011-2022 走看看