zoukankan      html  css  js  c++  java
  • poj2398计算几何叉积

    Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore.
    Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top:


    We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.Input

    The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard.

    A line consisting of a single 0 terminates the input.

    Output

    For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.

    Sample Input

    4 10 0 10 100 0
    20 20
    80 80
    60 60
    40 40
    5 10
    15 10
    95 10
    25 10
    65 10
    75 10
    35 10
    45 10
    55 10
    85 10
    5 6 0 10 60 0
    4 3
    15 30
    3 1
    6 8
    10 10
    2 1
    2 8
    1 5
    5 5
    40 10
    7 9
    0
    

    Sample Output

    Box
    2: 5
    Box
    1: 4
    2: 1
    
    和poj2318几乎一模一样,就是要排个序,二分就行了,判断二分状态用叉积
    #include<map>
    #include<set>
    #include<list>
    #include<cmath>
    #include<queue>
    #include<stack>
    #include<vector>
    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define pi acos(-1)
    #define ll long long
    #define mod 1000000007
    
    using namespace std;
    
    const int N=1005,maxn=100005,inf=0x3f3f3f3f;
    
    struct point{
        int x,y;
    };
    struct line{
       point a,b;
    }l[N];
    int num[N],n,m,res[N];
    
    bool comp(const line &u,const line &v)
    {
        if(u.a.x!=v.a.x)return u.a.x<v.a.x;
        return u.a.y<v.a.y;
    }
    bool ok(int m,int x,int y)
    {
        float f=(l[m].b.x-l[m].a.x)*(y-l[m].a.y)-(l[m].b.y-l[m].a.y)*(x-l[m].a.x);
        if(f>0)return 1;
        return 0;
    }
    void Bsearch(int u,int v)
    {
        int l=0,r=n+1;
        for(int i=0;i<50;i++)
        {
            int mid=(l+r)/2;
            if(ok(mid,u,v))l=mid;
            else r=mid;
        }
        num[l]++;
    }
    int main()
    {
        while(cin>>n,n){
            memset(num,0,sizeof(num));
            cin>>m>>l[0].a.x>>l[0].a.y>>l[n+1].b.x>>l[n+1].b.y;
            for(int i=1;i<=n;i++)
            {
                cin>>l[i].a.x>>l[i].b.x;
                l[i].a.y=l[0].a.y;
                l[i].b.y=l[n+1].b.y;
            }
            sort(l,l+n+1,comp);
            for(int i=0;i<m;i++)
            {
                int u,v;
                cin>>u>>v;
                Bsearch(u,v);
            }
            cout<<"Box"<<endl;
            memset(res,0,sizeof(res));
            for(int i=0;i<=n;i++)res[num[i]]++;
            for(int i=1;i<=n;i++)
                if(res[i]!=0)
                   cout<<i<<": "<<res[i]<<endl;
        }
        return 0;
    }
  • 相关阅读:
    vue展开过度动画
    css3,transition,animation两种动画实现区别
    css3动画
    html浏览器高度和宽度和其他dom获取
    afert和b的伪类画三角形
    java导入web项目httpservlet报错
    小程序事件
    Python动态语言的特性
    非关系型数据库之Redis
    深度学习必备基础知识
  • 原文地址:https://www.cnblogs.com/acjiumeng/p/6681716.html
Copyright © 2011-2022 走看看