zoukankan      html  css  js  c++  java
  • poj2594最小顶点覆盖+传递闭包

    传递闭包最开始是在Floyd-Warshall算法里面出现的,当时这算法用的很少就被我忽视了。。

    传递闭包是指如果i能到达k,并且k能到达j,那么i就能到达j

    Have you ever read any book about treasure exploration? Have you ever see any film about treasure exploration? Have you ever explored treasure? If you never have such experiences, you would never know what fun treasure exploring brings to you. 
    Recently, a company named EUC (Exploring the Unknown Company) plan to explore an unknown place on Mars, which is considered full of treasure. For fast development of technology and bad environment for human beings, EUC sends some robots to explore the treasure. 
    To make it easy, we use a graph, which is formed by N points (these N points are numbered from 1 to N), to represent the places to be explored. And some points are connected by one-way road, which means that, through the road, a robot can only move from one end to the other end, but cannot move back. For some unknown reasons, there is no circle in this graph. The robots can be sent to any point from Earth by rockets. After landing, the robot can visit some points through the roads, and it can choose some points, which are on its roads, to explore. You should notice that the roads of two different robots may contain some same point. 
    For financial reason, EUC wants to use minimal number of robots to explore all the points on Mars. 
    As an ICPCer, who has excellent programming skill, can your help EUC?

    Input

    The input will consist of several test cases. For each test case, two integers N (1 <= N <= 500) and M (0 <= M <= 5000) are given in the first line, indicating the number of points and the number of one-way roads in the graph respectively. Each of the following M lines contains two different integers A and B, indicating there is a one-way from A to B (0 < A, B <= N). The input is terminated by a single line with two zeros.

    Output

    For each test of the input, print a line containing the least robots needed.

    Sample Input

    1 0
    2 1
    1 2
    2 0
    0 0
    

    Sample Output

    1
    1
    2
    题意:放最小的机器人使得能够访问到所有顶点,机器人不能后退就是指有向图
    题解:刚开始居然以为用拓扑能做,后来发现蠢了,还是DAG的最小顶点覆盖问题,加一个传递闭包就行了
    #include<map>
    #include<set>
    #include<cmath>
    #include<queue>
    #include<stack>
    #include<vector>
    #include<cstdio>
    #include<cstdlib>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define pi acos(-1)
    #define ll long long
    #define mod 1000000007
    
    using namespace std;
    
    const int N=500+5,maxn=100+5,inf=0x3f3f3f3f;
    
    int n,color[N];
    bool used[N],ok[N][N];
    
    bool match(int x)
    {
        for(int i=1;i<=n;i++)
        {
            if(!used[i]&&ok[x][i])
            {
                used[i]=1;
                if(color[i]==-1||match(color[i]))
                {
                    color[i]=x;
                    return 1;
                }
            }
        }
        return 0;
    }
    int main()
    {
        ios::sync_with_stdio(false);
        cin.tie(0);
        int m;
        while(cin>>n>>m,n||m){
            memset(ok,0,sizeof ok);
            while(m--){
                int a,b;
                cin>>a>>b;
                ok[a][b]=1;
            }
            for(int i=1;i<=n;i++)
            {
                for(int j=1;j<=n;j++)
                {
                    if(!ok[i][j])
                    {
                        for(int k=1;k<=n;k++)
                        {
                            if(ok[i][k]&&ok[k][j])
                                ok[i][j]=1;
                        }
                    }
                }
            }
            int ans=0;
            memset(color,-1,sizeof color);
            for(int i=1;i<=n;i++)
            {
                memset(used,0,sizeof used);
                ans+=match(i);
            }
            cout<<n-ans<<endl;
        }
        return 0;
    }
    View Code
  • 相关阅读:
    初学C#线程
    初学C#线程二
    JQuery Ajax
    算法测试
    个人报告
    202120221课程设计第三周进展
    socket测试3
    202120221课程设计任务理解与分工
    嵌入式基础
    202120221课程设计第四周进展
  • 原文地址:https://www.cnblogs.com/acjiumeng/p/6748975.html
Copyright © 2011-2022 走看看