zoukankan      html  css  js  c++  java
  • poj2739尺取法+素数筛

    Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime 
    numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20. 
    Your mission is to write a program that reports the number of representations for the given positive integer.

    Input

    The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

    Output

    The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.

    Sample Input

    2
    3
    17
    41
    20
    666
    12
    53
    0

    Sample Output

    1
    1
    2
    3
    0
    0
    1
    2
    题意:给你一个数,要求找出它能用连续素数相加而成的个数
    题解:一看就知道要先来一个素数筛啦。然后用另一个数组保存2到10000的尺取结果,输入后就能直接输出了,刚开始还担心会不会TLE@-@,结果居然只花了188ms
    果然还是打表大法好啊
    #include<map>
    #include<set>
    #include<cmath>
    #include<queue>
    #include<stack>
    #include<vector>
    #include<cstdio>
    #include<cstdlib>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define pi acos(-1)
    #define ll long long
    #define mod 1000000007
    
    using namespace std;
    
    const int N=20000+5,maxn=10000+5,inf=0x3f3f3f3f;
    
    int p[maxn],ans[maxn];
    bool isprime[N];
    
    void getprime()
    {
        int k=0;
        for(int i=0;i<N;i++)isprime[i]=1;
        isprime[0]=isprime[1]=0;
        for(int i=2;i<N;i++)
        {
            if(isprime[i])
            {
                p[k++]=i;
                for(int j=2*i;j<N;j+=i)
                    isprime[j]=0;
            }
        }
    }
    int solve(int x)//对x进行尺取
    {
        int s=0,t=0,sum=0,ans=0;
        while(t<2000){
            while(sum<x&&t<2000){
                sum+=p[t];
                t++;
            }
            if(sum<x)break;
            if(sum==x)ans++;
            sum-=p[s];
            s++;
        }
        return ans;
    }
    int main()
    {
        ios::sync_with_stdio(false);
        cin.tie(0);
        getprime();
        for(int i=2;i<=10000;i++)ans[i]=solve(i);
        int n;
        while(cin>>n,n){
            cout<<ans[n]<<endl;
        }
        return 0;
    }
    View Code
  • 相关阅读:
    CodeForces
    CodeForces
    CodeForces
    HDU 6704 K-th occurrence(后缀数组,主席树,st表,二分)
    AcWing 1004. 品酒大会 (后缀数组,并查集)
    Gym
    codeforces 2100左右的DS题 做题记录
    P4768 [NOI2018] 归程 做题记录
    CSP 2021 智熄记
    「随笔」论打羽毛球的正确姿势
  • 原文地址:https://www.cnblogs.com/acjiumeng/p/6752672.html
Copyright © 2011-2022 走看看