zoukankan      html  css  js  c++  java
  • poj2566尺取变形

    Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: "But I want to use feet, not meters!"). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We'll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t. 

    You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.

    Input

    The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.

    Output

    For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.

    Sample Input

    5 1
    -10 -5 0 5 10
    3
    10 2
    -9 8 -7 6 -5 4 -3 2 -1 0
    5 11
    15 2
    -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
    15 100
    0 0
    

    Sample Output

    5 4 4
    5 2 8
    9 1 1
    15 1 15
    15 1 15
    题意:找连续的数使得和的绝对值和给定数差最小
    题解:想了很久没想到,****因为尺取法必须单调数列才行,而且是求连续和****,先求前缀和,给其排序,再进行尺取
    因为s不能等于t,当s==t时,t要++;sum>k时,向后移动s++,反之t++;
    #include<map>
    #include<set>
    #include<cmath>
    #include<queue>
    #include<stack>
    #include<vector>
    #include<cstdio>
    #include<cstdlib>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define pi acos(-1)
    #define ll long long
    #define mod 1000000007
    
    using namespace std;
    
    const int N=100000+5,maxn=10000+5,inf=0x3f3f3f3f;
    
    struct edge{
       int v,id;
    }a[N];
    int n;
    
    bool comp(const edge &a,const edge &b)
    {
        return a.v<b.v;
    }
    void solve(int x)
    {
        int s=0,t=1,ss,tt,sum,ans,minn=inf;
        while(s<=n&&t<=n&&minn!=0){
            sum=a[t].v-a[s].v;
            if(abs(sum-x)<minn)
            {
                minn=abs(sum-x);
                ans=sum;
                ss=a[s].id;
                tt=a[t].id;
            }
            if(sum>x)s++;
            else if(sum<x)t++;
            else break;
            if(t==s)t++;
        }
        if(ss>tt)swap(ss,tt);
        cout<<ans<<" "<<ss+1<<" "<<tt<<endl;
    }
    int main()
    {
        ios::sync_with_stdio(false);
        cin.tie(0);
        int k,s;
        while(cin>>n>>k,n||k){
            a[0].v=a[0].id=0;
            for(int i=1;i<=n;i++)
            {
                int p;
                cin>>p;
                a[i].v=a[i-1].v+p;
                a[i].id=i;
            }
            sort(a,a+n+1,comp);
            while(k--){
                cin>>s;
                solve(s);
            }
        }
        return 0;
    }
    View Code
  • 相关阅读:
    元素显示模式
    cssW3c书写规范
    css字体标签相关
    标签显示模式
    css权重问题
    成员变量和局部变量的区别
    利用反射执行Spring方法,支持参数自动转换
    通用计价的简单代码实现
    关于数据迁移的记录
    【设计模式】----- 观察者模式
  • 原文地址:https://www.cnblogs.com/acjiumeng/p/6754683.html
Copyright © 2011-2022 走看看