zoukankan      html  css  js  c++  java
  • poj2785双向搜索

    The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

    Input

    The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .

    Output

    For each input file, your program has to write the number quadruplets whose sum is zero.

    Sample Input

    6
    -45 22 42 -16
    -41 -27 56 30
    -36 53 -37 77
    -36 30 -75 -46
    26 -38 -10 62
    -32 -54 -6 45
    

    Sample Output

    5
    

    Hint

    Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).
    题意:求四个数的和为0的情况有几种
    题解:折半枚举+sort,,很重要的小技巧:upper_bound(a,a+n,s)-low_bound(a,a+n,s)表示a数组(已排序)里等于s的个数,
    刚开始用if(all[lower_bound(all,all+n*n,-a[i]-b[j])-all]==-a[i]-b[j])处理wa了,发现原来是因为只算了一个相等的情况,要是有几个同时等于就漏了
    #include<map>
    #include<set>
    #include<cmath>
    #include<queue>
    #include<stack>
    #include<vector>
    #include<cstdio>
    #include<iomanip>
    #include<cstdlib>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define pi acos(-1)
    #define ll long long
    #define mod 1000000007
    
    using namespace std;
    
    const double g=10.0,eps=1e-9;
    const int N=4000+5,maxn=10000+5,inf=0x3f3f3f3f;
    
    ll a[N],b[N],c[N],d[N];
    ll all[N*N];
    
    int main()
    {
        ios::sync_with_stdio(false);
        cin.tie(0);
     //   cout<<setiosflags(ios::fixed)<<setprecision(2);
        ll n;
        while(cin>>n){
            for(ll i=0;i<n;i++)cin>>a[i]>>b[i]>>c[i]>>d[i];
            for(ll i=0;i<n;i++)
            {
                for(ll j=0;j<n;j++)
                {
                    all[i*n+j]=c[i]+d[j];
                }
            }
            sort(all,all+n*n);
            ll ans=0;
            for(ll i=0;i<n;i++)
            {
                for(ll j=0;j<n;j++)
                {
                    ans+=upper_bound(all,all+n*n,-a[i]-b[j])-lower_bound(all,all+n*n,-a[i]-b[j]);
                }
            }
            cout<<ans<<endl;
        }
        return 0;
    }
    View Code
  • 相关阅读:
    实用画刷填充图形
    PDA连接远程数据库的三种解决方案
    图形编程入门之如何创建用于绘制的 Graphics 对象
    使用渐变画笔填充形状
    使用钢笔绘制线条和形状
    How to: Display a Gradient Fill
    实现防火墙的“电话已关机”,“此号码已停机”,“号码不存在”等提示音的方法
    MSDN课程
    android振动器
    android视频播放
  • 原文地址:https://www.cnblogs.com/acjiumeng/p/6757106.html
Copyright © 2011-2022 走看看