zoukankan      html  css  js  c++  java
  • poj3080kmp或者暴力

    The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated. 

    As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers. 

    A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC.

    Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

    Input

    Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:
    • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
    • m lines each containing a single base sequence consisting of 60 bases.

    Output

    For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.

    Sample Input

    3
    2
    GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
    AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
    3
    GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
    GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
    GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
    3
    CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
    ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
    AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

    Sample Output

    no significant commonalities
    AGATAC
    CATCATCAT
    题意:找最长的公共字串,长度相同就找最小的(这一点wa了我13遍!!!)
    题解:kmp或者直接暴力列举
    kmp:
    #include<map>
    #include<set>
    #include<cmath>
    #include<queue>
    #include<stack>
    #include<vector>
    #include<cstdio>
    #include<iomanip>
    #include<cstdlib>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define pi acos(-1)
    #define ll long long
    #define mod 1000000007
    #define ls l,m,rt<<1
    #define rs m+1,r,rt<<1|1
    
    using namespace std;
    
    const double g=10.0,eps=1e-9;
    const int N=10+5,maxn=60+5,inf=0x3f3f3f3f;
    
    string s[N];
    int Next[maxn];
    
    void getnext(string str,int slen)
    {
        int k=-1;
        Next[0]=-1;
        for(int i=1;i<slen;i++)
        {
            while(k>-1&&str[k+1]!=str[i])k=Next[k];
            if(str[k+1]==str[i])k++;
            Next[i]=k;
        }
    }
    bool kmp(string ptr,int plen,string str,int slen)
    {
        int k=-1;
        for(int i=0;i<plen;i++)
        {
            while(k>-1&&str[k+1]!=ptr[i])k=Next[k];
            if(str[k+1]==ptr[i])k++;
            if(k==slen-1)return 1;
        }
        return 0;
    }
    int main()
    {
        ios::sync_with_stdio(false);
        cin.tie(0);
     //   cout<<setiosflags(ios::fixed)<<setprecision(2);
        int t,n;
        cin>>t;
        while(t--){
            cin>>n;
            for(int i=0;i<n;i++)cin>>s[i];
            string ans="";
            for(int i=1;i<=s[0].size();i++)//长度
            {
                for(int j=0;j<=s[0].size()-i;j++)//起点
                {
                    string op=s[0].substr(j,i);
                    getnext(op,op.size());
                    bool flag=0;
                    for(int k=1;k<n;k++)
                        if(!kmp(s[k],s[k].size(),op,op.size()))
                            flag=1;
                    if(!flag)
                    {
                        if(ans.size()<op.size())ans=op;
                        else if(ans.size()==op.size())ans=min(ans,op);
                    }
                }
            }
            if(ans.size()<3)cout<<"no significant commonalities"<<endl;
            else cout<<ans<<endl;
        }
        return 0;
    }
    View Code

    暴力:

    #include<map>
    #include<set>
    #include<cmath>
    #include<queue>
    #include<stack>
    #include<vector>
    #include<cstdio>
    #include<iomanip>
    #include<cstdlib>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define pi acos(-1)
    #define ll long long
    #define mod 1000000007
    #define ls l,m,rt<<1
    #define rs m+1,r,rt<<1|1
    
    using namespace std;
    
    const double g=10.0,eps=1e-9;
    const int N=10+5,maxn=60+5,inf=0x3f3f3f3f;
    
    int Next[maxn];
    
    void getnext(string str,int slen)
    {
        int k=-1;
        Next[0]=-1;
        for(int i=1;i<slen;i++)
        {
            while(k>-1&&str[k+1]!=str[i])k=Next[k];
            if(str[k+1]==str[i])k++;
            Next[i]=k;
        }
    }
    bool kmp(string ptr,int plen,string str,int slen)
    {
        int k=-1;
        for(int i=0;i<plen;i++)
        {
            while(k>-1&&str[k+1]!=ptr[i])k=Next[k];
            if(str[k+1]==ptr[i])k++;
            if(k==slen-1)return 1;
        }
        return 0;
    }
    int main()
    {
        ios::sync_with_stdio(false);
        cin.tie(0);
     //   cout<<setiosflags(ios::fixed)<<setprecision(2);
        int t,n;
        cin>>t;
        while(t--){
            cin>>n;
            string str[15];
            for(int i=0;i<n;i++)cin>>str[i];
            string res="";
            for(int i=3;i<=60;i++)
            {
                for(int j=0;j<=60-i;j++)
                {
                    string tem=str[0].substr(j,i);
                 //   getnext(op,op.size());
                    bool flag=1;
                    for(int k=1;k<n;k++)
                        if(str[k].find(tem)==string::npos)
                        {
                            flag=0;
                            break;
                        }
                    if(flag&&res.size()<tem.size())res=tem;
                    else if(flag&&res.size()==tem.size()&&res>tem)res=tem;
                }
            }
            if(res=="")cout<<"no significant commonalities"<<endl;
            else cout<<res<<endl;
        }
        return 0;
    }
    View Code
  • 相关阅读:
    再度学习MYSQL-----(1.基础)
    GIL解释器锁(进程与线程的应用场景)
    Django学习三有关表的创建查询类
    Django学习二模板
    Django学习一
    JQuery学习一
    前端基础学习之css二
    前端基础之css一
    mysql----单表多表查询
    MySQL-----表操作
  • 原文地址:https://www.cnblogs.com/acjiumeng/p/6818213.html
Copyright © 2011-2022 走看看