zoukankan      html  css  js  c++  java
  • 【BFS】【HDOJ-1195】Open the Lock

    Problem Description
    Now an emergent task for you is to open a password lock. The password is consisted of four digits. Each digit is numbered from 1 to 9.
    Each time, you can add or minus 1 to any digit. When add 1 to '9', the digit will change to be '1' and when minus 1 to '1', the digit will change to be '9'. You can also exchange the digit with its neighbor. Each action will take one step.

    Now your task is to use minimal steps to open the lock.

    Note: The leftmost digit is not the neighbor of the rightmost digit.
     
    Input
    The input file begins with an integer T, indicating the number of test cases.

    Each test case begins with a four digit N, indicating the initial state of the password lock. Then followed a line with anotther four dight M, indicating the password which can open the lock. There is one blank line after each test case.
     
    Output
    For each test case, print the minimal steps in one line.
     
    Sample Input
    2
    1234
    2144
     
    1111
    9999
     
    Sample Output
    2
    4
     
    思路:
    BFS  可以有+1 -1 交换三种线路 进行BFS
     
    参考代码:
    #include <iostream>
    #include <string>
    #include <queue>
    using namespace std;
    char s1[5],s2[5];
    int a[4],b[4];
    int bfs();
    int mark[10000];
    typedef struct
    {
        int x[4];
        int step;
    }node;
    int main()
    {
        int t;
        cin>>t;
        while(t--)
        {
            cin>>s1>>s2;
            int i;
            for(i=0;i<4;i++)
            {
                a[i]=s1[i]-'0';
                b[i]=s2[i]-'0';
            }
            cout<<bfs()<<endl;
        }
        return 0;
    }
    
    int bfs()
    {
        memset(mark,0,sizeof(mark));
        node temp;
        queue<node> q;
        temp.step=0;
        int i;
        for(i=0;i<4;i++)
            temp.x[i]=a[i];
        q.push(temp);
        mark[a[0]*1000+a[1]*100+a[2]*10+a[3]]=1;
        while(!q.empty())
        {
            for(i=0;i<11;i++)
            {
                if(i<4)//加
                {
                    node newl=q.front();
                    newl.x[i]=q.front().x[i]+1;
                    if(newl.x[i]==10)
                        newl.x[i]=1;
                    if(!mark[newl.x[0]*1000+newl.x[1]*100+newl.x[2]*10+newl.x[3]])
                    {
                        mark[newl.x[0]*1000+newl.x[1]*100+newl.x[2]*10+newl.x[3]]=1;
                        newl.step=q.front().step+1;
                        q.push(newl);
                        if(newl.x[0]==b[0]&&newl.x[1]==b[1]&&newl.x[2]==b[2]&&newl.x[3]==b[3])
                            return newl.step;
                    }
                }
                else if(i<8)//减
                {
                    node newl=q.front();
                    newl.x[i-4]=q.front().x[i-4]-1;
                    if(newl.x[i-4]==0)
                        newl.x[i-4]=9;
                    if(!mark[newl.x[0]*1000+newl.x[1]*100+newl.x[2]*10+newl.x[3]])
                    {
                        mark[newl.x[0]*1000+newl.x[1]*100+newl.x[2]*10+newl.x[3]]=1;
                        newl.step=q.front().step+1;
                        q.push(newl);
                        if(newl.x[0]==b[0]&&newl.x[1]==b[1]&&newl.x[2]==b[2]&&newl.x[3]==b[3])
                            return newl.step;
                    }
                }
                else
                {
                    node newl=q.front();
                    int temp;
                    temp=q.front().x[i-7];
                    newl.x[i-8]=temp;
                    newl.x[i-7]=q.front().x[i-8];
                    if(!mark[newl.x[0]*1000+newl.x[1]*100+newl.x[2]*10+newl.x[3]])
                    {
                        mark[newl.x[0]*1000+newl.x[1]*100+newl.x[2]*10+newl.x[3]]=1;
                        newl.step=q.front().step+1;
                        q.push(newl);
                        if(newl.x[0]==b[0]&&newl.x[1]==b[1]&&newl.x[2]==b[2]&&newl.x[3]==b[3])
                            return newl.step;
                    }
                }
            }
            q.pop();
        }
    }
    
  • 相关阅读:
    使用npm安装包失败的解决办法(使用npm国内镜像介绍)
    JavaScript的变量、作用域和内存问题
    JavaScript的基本概念
    在Html中使用JavaScript
    JavaScript简介
    C++为了兼容,所以并不是纯面向对象编程语言
    C++四种不同的对象生存方式
    Java BigDecimal使用
    ext 对齐
    ext grid 子表格
  • 原文地址:https://www.cnblogs.com/ahu-shu/p/3521513.html
Copyright © 2011-2022 走看看