zoukankan      html  css  js  c++  java
  • 九度OnlineJudge之1004:Median

    题目描述:

        Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the non-decreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.
        Given two increasing sequences of integers, you are asked to find their median.

    输入:

        Each input file may contain more than one test case.
        Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤1000000) is the size of that sequence. Then N integers follow, separated by a space.
        It is guaranteed that all the integers are in the range of long int.

    输出:

        For each test case you should output the median of the two given sequences in a line.

    样例输入:
    4 11 12 13 14
    5 9 10 15 16 17
    样例输出:
               13
    #include <iostream>
    #include <vector>
    #include <algorithm>
    using namespace std;
    
    
    
    
    int main()
    {
    vector<long> vec;
    
    int size1=0,size2=0;
    long t=0;
    while(cin>>size1)
    {
     int n1=size1;
     vec.clear();
     while(n1--)
     {cin>>t;vec.push_back(t);}
     cin>>size2;
     
     int n2 =size2;
     while(n2--)
     {cin>>t;vec.push_back(t);}
    
    sort(vec.begin(),vec.end());
    
     int s=size1+size2;
    if(s%2)
    cout<<*(vec.begin()+s/2)<<endl;
    else
    cout<<*(vec.begin()+s/2-1)<<endl;
    
    
    
    }
    
      //system("pause");
    	return 0;
    }
    

  • 相关阅读:
    java 打包jar问题 含资源文件
    电脑 自动化脚本
    haproxy 安装配置
    rsa
    org.hibernate.tool.schema.spi.CommandAcceptanceException: Error executing DDL via JDBC Statement
    java aop 日志打印 正则设置
    mysql 导入csv 转义
    linux 文件同步
    CSS3 流动边框
    httponlycookie
  • 原文地址:https://www.cnblogs.com/ainima/p/6331260.html
Copyright © 2011-2022 走看看