zoukankan      html  css  js  c++  java
  • 九度OnlineJudge之1468:Sharing

    题目描述:

    To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.

    Figure 1

    You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

    输入:

    For each case, the first line contains two addresses of nodes and a positive N (<= 10^5), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

    Then N lines follow, each describes a node in the format:

    Address Data Next

    where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Next is the position of the next node.

    输出:

    For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.

    样例输入:
    11111 22222 9
    67890 i 00002
    00010 a 12345
    00003 g -1
    12345 D 67890
    00002 n 00003
    22222 B 23456
    11111 L 00001
    23456 e 67890
    00001 o 00010
    00001 00002 4
    00001 a 10001
    10001 s -1
    00002 a 10002
    10002 t -1
    样例输出:
    67890
    -1
    #include <iostream>
    #include <string.h>
     
    using namespace std;
    
    
    int Link[100000];//之前是小写的link数组提交的时候一直报错,查看错误发现与编译环境里面的命名冲突了,改了就好了
    char data[100000];
    
    int main()
    {
    	int start1,start2,N;
    	  int pre,next;
    	  char ch;
    	while(cin>>start1>>start2>>N)
    	{
    
    		int len1 = 0;
    		int len2 = 0;
    		int  p1 =start1;
    		int  p2 =start2;
    		int k1 = 0;
    		int k2 = 0;
    	   memset(Link,0,sizeof(Link));
    	   memset(data,0,sizeof(data));
    	      while(N--)
    		  {
    		     cin>>pre>>ch>>next;
    			 Link[pre] = next;
    			 data[pre] = ch; 
    		  }
    
    	 while(p1 != -1)
    	 {
    	    len1++;
    		p1 = Link[p1]; 
    	 }
    	 while(p2 != -1)
    	 {
    		 len2++;
    		 p2 = Link[p2]; 
    	 }
    
    	   p1 = start1;
    	   p2 = start2;
    	   int len = len1 - len2;
    	 if (len > 0)//第一条链长
    	 {
    		 while(len>0)
    		 {
    		     p1 = Link[p1];
    			 len--; 
    		 }
    
    
    	 }
    	 else //第二条链长
    	 {
    	    while(len<0)
    		{
    		   p2 = Link[p2];
    		   len++;
    		}
    	 }
    
    	while(p1 !=-1 && p2 !=-1)
    	{
    	    if (p1 == p2)
    	     break;
    		else
    		{
    		p1 =Link[p1];
    		p2 =Link[p2];
    		}
    	}
    
    	if (p1 ==-1 || p2 ==-1)
        cout<<"-1"<<endl;
        else
    	{
    		cout.width(5);
    		cout.fill('0');
    	  cout<<p1<<endl;
    	}
    
    }
       //system("pause");
    	return 0;
    }
    
    
    

  • 相关阅读:
    关于基础排序算法的思考--插入排序
    关于购物车的多层复选全选
    随便写写
    第一篇小博文
    C# 遍历目录下所有文件方法
    C#驱动MongoDB官方中查询条件Query用法
    mongodb 修改远程连接
    Python 爬虫练习低调163疫情数据辽宁地图
    jquery easyui datagrid drop事件执行顺序
    https request报错 ServicePointManager.SecurityProtocol 搞定
  • 原文地址:https://www.cnblogs.com/ainima/p/6331273.html
Copyright © 2011-2022 走看看