zoukankan      html  css  js  c++  java
  • 浙江大学PAT上机题解析之1008. Elevator (20)

    1008. Elevator (20)

    时间限制 
    400 ms
    内存限制 
    32000 kB
    代码长度限制 
    16000 B
    判题程序   
    Standard
    作者   
    CHEN, Yue

    The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

    For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

    Input Specification:

    Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

    Output Specification:

    For each test case, print the total time on a single line.

    Sample Input:
    3 2 3 1
    
    Sample Output:
    41
    
     
    #include <iostream>
    #include <vector>
    
    using namespace std;
    
    
    
    int main()
    {
       int M;
       int temp;
       int sec=0;
       cin>>M;
       vector<int> vec;
       vector<int>::iterator it,it1;
       while(M--)
       {
       cin>>temp;
       vec.push_back(temp);
       }
    
       sec += (*vec.begin())*6;
    
    
       for ( it = vec.begin();it!=vec.end()-1;it++)
       {
    	    it1 = it + 1;
    	   if ((*it1) > (*it))
    	   {
    		   sec += ((*it1)-(*it))*6 ;
    	   }
    	   else
    		   if ((*it1) < (*it))
    		   {
    			   sec += ((*it)-(*it1))*4 ;
    		   }	  
       }
    
       sec += vec.size()*5;
       cout<<sec<<endl;
    
     // system("pause");
    	return 0;
    }

  • 相关阅读:
    设计模式——迭代器模式
    FTP服务:FileZilla的配置和使用
    FTP服务:使用FileZilla搭建FTP服务
    FTP服务:ISS搭建服务
    javaweb项目使用RSA算法
    我在博客园的第一篇博客
    杰表打印跟乱码修改
    jsp页面角色判断
    test : 摘自 https://www.cnblogs.com/yyman001/p/3366764.html
    mybatis中sql查询不到数据单独运行sql可以获取数据
  • 原文地址:https://www.cnblogs.com/ainima/p/6331278.html
Copyright © 2011-2022 走看看