zoukankan      html  css  js  c++  java
  • hdu1213 How Many Tables

    How Many Tables

    http://acm.hdu.edu.cn/showproblem.php?pid=1213

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 9188    Accepted Submission(s): 4510


    Problem Description
    Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

    One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

    For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
     
    Input
    The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
     
    Output
    For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
     
    Sample Input
    2
    5 3
    1 2
    2 3
    4 5
     
    5 1
    2 5
    Sample Output
    2
    4
    简单的并查集
    #include<iostream>
    #include<string.h>
    #include<stdio.h>
    using namespace std;
    int father[1010],num[1010];
    int Find(int x)
    {
        int r=x,tmp;
        while(r!=father[r])
        {
            r=father[r];
        }
        while(x!=r)
        {
            tmp=father[x];
            father[x]=r;
            x=tmp;
        }
        return r;
    }
    void Union(int a,int b)
    {
        a=Find(a);b=Find(b);
        if(a!=b)
        {
            father[a]=b;
            num[b]+=num[a];
            num[a]=0;
        }
    }
    int main()
    {
        int t,n,m,i,j;
        cin>>t;
        while(t--)
        {
            cin>>n>>m;
            for(i=1;i<=n;i++)
            {
                 father[i]=i;num[i]=1;
            }
    
            int p1,p2;
            for(i=1;i<=m;i++)
            {
                scanf("%d%d",&p1,&p2);
                Union(p1,p2);
            }
             int sum=0,sum2=0;
             for(i=1;i<=n;i++)
               if(num[i]!=0)
                  {
                      sum++;
                      sum2+=num[i];
                  }
    
             cout<<n-sum2+sum<<endl;
        }
    }
    View Code
  • 相关阅读:
    Martin Fowler关于IOC和DI的文章(原版)
    父类引用指向子类对象详解
    求中位数总结
    二叉树的遍历方法
    MySQL知识小结
    栈和队列的基础算法学习(EPI)
    链表的基础题目学习(EPI)
    数组和字符串的基础题目学习(EPI)
    基本类型算法题目学习(EPI)
    被C语言操作符优先级坑了
  • 原文地址:https://www.cnblogs.com/ainixu1314/p/3217560.html
Copyright © 2011-2022 走看看